Microsoft Excel

Herbers Excel/VBA-Archiv

Berechnungen mit Datum

Betrifft: Berechnungen mit Datum von: klaus
Geschrieben am: 11.10.2007 12:50:21

Hallo Excelaner,

habe ein weiteres Problem.

Ich hole mit folgender Formel, sie steht im Feld P1, aus dem Blatt Std =DATUM(Std!$A$2;Std!B3;1)
ein Datum mit Anzeige des Monats (z.B. Januar /variabel einstellbar)

in Std B3 steht 1 (1=variabel einstellbar für den Monat)
in Std A3=TEXT(DATUM(A1;B3;1);"MMMM")
in Std A2 steht 2007

Nun möchte ich wissen wie viele Samstage hat dieser Monat (Januar 2007), die Anzahl soll dann in V11
des aktiven Blatts stehen.

Möglich ?? Wenn wie ???

Schon mal Danke an alle freundlichen Helfer

Klaus

  

Betrifft: AW: Berechnungen mit Datum von: c0bRa
Geschrieben am: 11.10.2007 12:55:05

Hio...

Anzahl bestimmter Wochentage (z.B. Montage) in einem Zeitraum * (251)


Rückmeldung nicht vergessen...
c0bRa
Perl ist die einzige Sprache, die vor und nach einer RSA-Verschlüsselung gleich aussieht.


  

Betrifft: AW: Berechnungen mit Datum von: Christian
Geschrieben am: 11.10.2007 13:10:58

Hallo Klaus,

als Ansatz:

Tabelle3

 AB
112.01.20074
2  

Formeln der Tabelle
ZelleFormel
B1=SUMMENPRODUKT((WOCHENTAG(ZEILE(INDIREKT("A"&A1-TAG(A1)+1&":"&"A"&DATUM(JAHR(A1); MONAT(A1)+1;0))); 2)=6)*1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

MfG Christian


 

Beiträge aus den Excel-Beispielen zum Thema "Berechnungen mit Datum"