Das Archiv des Excel-Forums

Summenprodukt + Externe Bezüge

Bild

Betrifft: Summenprodukt + Externe Bezüge
von: zone

Geschrieben am: 15.02.2008 14:43:44

Hallo zusammen,

ich habe folgendes Problem:

In einer tabelle werden täglich Produktionsdaten erfasst, diese Tabelle wird als datenstamm verwendet.

Ich habe eine Zweite Tabelle, welche beim öffnen mir eine Spalte mit den aktuellen Monatsdaten erzeugt (Datum eines jeden Tages)

Neben anderen Sachen wie automatischem Speichern und deaktivieren der Makros am Monatsender in der Kopie (was alles fkt.) hänge ich an folgendem Problem:

In einer Zelle soll die Gesamtzahl der Produzierten Teile des gestrigen tages ausgegeben werden.

Die Datentabelle gestaltet sich so:
A B C
11.02.08 123a 1
11.02.08 123b 5
11.02.08 123xy 8
11.02.02 352as 2

Es soll wenn das Datum in Spalte A erfüllt ist, die ersten drei Buchstaben in Spalte B erfüllt sind die Anzahl der Teile in C aufsummiert werden.

Ich hoffe ich kann mich einigermassen ausdruecken?!

Hier meine Formel, die fkt. so lange bis ich die externen Bezüge hinzufüge:

=SUMMENPRODUKT((export.xls!A1:A2000=heute()-1)*(export.xls!B1:B2000=LINKS((export.xls!B1:B2000)"123") *(C1:C2000))

export.xls! wird von Excel so umgewandelt, ich habe natuerlich den Kompletten Pfad in ' eingegeben.

Momentan ist auch noch n Fehler bei der LINKS Fkt. drin, gehe ich zumindest von aus aber damit probiere ich grad noch rum.

Viele Dank im voraus!!

Bild

Betrifft: AW: Summenprodukt + Externe Bezüge
von: Renee
Geschrieben am: 15.02.2008 15:04:41
Hi zone (Excel gut?) ....was Eltern heutzutage für Namen einfallen...
ungefähr so:


=SUMMENPRODUKT(('[export.xls]Tabelle1'!A1:A2000=heute()-1)*(LINKS('[export.xls]Tabelle1'!B1:B2000;3) ="123") *('[export.xls]Tabelle1'!C1:C2000)) 


GreetZ Renée

 Bild

Excel-Beispiele zum Thema "Summenprodukt + Externe Bezüge"

Externe Verknüpfungen lokal umleiten download Alle externen Links löschen download
Textdatei als externe Datei per VBA einbinden download Zeichenfolgen über Doppelklick in externen Bezug umwandeln. download
Wert in externer Mappe suchen und mit Format übernehmen. download Alle externen Links löschen und in Werte umwandeln download
Symbolleiste zum Aufruf externer Anwendungen erstellen download