Microsoft Excel

Herbers Excel/VBA-Archiv

Bestimmte Einträge filtern

Betrifft: Bestimmte Einträge filtern von: Erwin
Geschrieben am: 01.03.2008 16:16:34

Hallo Excel-Freunde,

ich bereite gerade einen Bereitschaftsplan vor. Dazu habe ich mir einen ganz einfachen Monatskalender von B2-AF2 mit den Tagen und B3-AF3 mit dem Datum und in Spalte A die Namen vorbereitet. Darin stehen dann u.a. "T" für Tagesdienst und "N" für Nachtdienst. Ab Spalte AG4 zähle ich dann für jeden mit der Funktion Zählenwenn die T und N (k für krank usw.) zusammen. Klappt alles super. Aber jetzt möchte ich zusätzlich die T und N nur für Samstag und Sonntag noch herausfiltern. Aber mit zählenwenn klappt das nicht.
Gibt es vielleicht eine andere Möglichkeit, mit einer einfachen Formel dies zu realisieren?
Hoffentlich weiß jemand einen Rat.

Erwin

  

Betrifft: AW: selbst gelöst von: Erwin
Geschrieben am: 01.03.2008 17:52:14

Hallo Excel-Freunde,

habe es soeben selbst gelöst. Habe unter der gesamten Tabelle nochmal alle Namen aufgeführt und und mit einer wenn-Formel nach T und N nur in den Spalten Samstag und Sonntag suchen und eine 1 dazuschreiben lassen. Dann noch eine Quersumme und es klappt. Ein bisschen umständlich, aber es hilft!"!

Tschau Erwin


  

Betrifft: SUMMENPRODUKT von: Beate Schmitz
Geschrieben am: 01.03.2008 17:52:21

Hallo Erwin,

 AHAI
34Wochenende T
46Wochenende N

Formeln der Tabelle
ZelleFormel
AH3=SUMMENPRODUKT((WOCHENTAG(B$2:AF$2;2)>5)*(B$3:AF$3="T"))
AH4=SUMMENPRODUKT((WOCHENTAG(B$2:AF$2;2)>5)*(B$3:AF$3="N"))


Gruß,
Beate


  

Betrifft: AW: Bestimmte Einträge filtern von: Josef Ehrensberger
Geschrieben am: 01.03.2008 17:52:29

Hallo Erwin,

meinst du so?

Tabelle2

 ABCDEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAFAGAHAIAJAK
1                                     
2 DiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDo     
3 01020304050607080910111213141516171819202122232425262728293031TNkT WEN WE
4Name 1TN T     T N  T   TN  kk TN    64223
5Name 2                               00000
6Name 3                               00000
7Name 4                               00000
8Name 5                               00000
9Name 6                               00000
10Name 7                               00000
11Name 8                               00000
12Name 9                               00000
13Name 10                               00000

Formeln der Tabelle
ZelleFormel
AG4=ZÄHLENWENN($B4:$AF4;AG$3)
AH4=ZÄHLENWENN($B4:$AF4;AH$3)
AI4=ZÄHLENWENN($B4:$AF4;AI$3)
AJ4=SUMMENPRODUKT(($B4:$AF4=AG$3)*(WOCHENTAG($B$3:$AF$3;2)>5))
AK4=SUMMENPRODUKT(($B4:$AF4=AH$3)*(WOCHENTAG($B$3:$AF$3;2)>5))
Excel Tabellen im Web darstellen  Excel Jeanie HTML




Gruß Sepp





  

Betrifft: AW: Danke an Beate und Josef von: Erwin
Geschrieben am: 01.03.2008 18:03:26

Hallo Beate und Josef,

vielen Dank für eure Antworten, die sind natürlich um "ein ganzes Stück" besser!! Die Funktion SUMMENPRODUKT habe ich ehrlich gesagt noch nicht gekannt. Ich mach es so, wie ihr es beschrieben hat.

Danke noch mal für eure Bemühungen und
ein schönes Wochende

Erwin aus Bayern


 

Beiträge aus den Excel-Beispielen zum Thema "Bestimmte Einträge filtern"