Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
956to960
956to960
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Bestimmte Einträge filtern

Bestimmte Einträge filtern
01.03.2008 16:16:00
Erwin
Hallo Excel-Freunde,
ich bereite gerade einen Bereitschaftsplan vor. Dazu habe ich mir einen ganz einfachen Monatskalender von B2-AF2 mit den Tagen und B3-AF3 mit dem Datum und in Spalte A die Namen vorbereitet. Darin stehen dann u.a. "T" für Tagesdienst und "N" für Nachtdienst. Ab Spalte AG4 zähle ich dann für jeden mit der Funktion Zählenwenn die T und N (k für krank usw.) zusammen. Klappt alles super. Aber jetzt möchte ich zusätzlich die T und N nur für Samstag und Sonntag noch herausfiltern. Aber mit zählenwenn klappt das nicht.
Gibt es vielleicht eine andere Möglichkeit, mit einer einfachen Formel dies zu realisieren?
Hoffentlich weiß jemand einen Rat.
Erwin

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: selbst gelöst
01.03.2008 17:52:00
Erwin
Hallo Excel-Freunde,
habe es soeben selbst gelöst. Habe unter der gesamten Tabelle nochmal alle Namen aufgeführt und und mit einer wenn-Formel nach T und N nur in den Spalten Samstag und Sonntag suchen und eine 1 dazuschreiben lassen. Dann noch eine Quersumme und es klappt. Ein bisschen umständlich, aber es hilft!"!
Tschau Erwin

SUMMENPRODUKT
01.03.2008 17:52:00
Beate
Hallo Erwin,
 AHAI
34Wochenende T
46Wochenende N

Formeln der Tabelle
ZelleFormel
AH3=SUMMENPRODUKT((WOCHENTAG(B$2:AF$2;2)>5)*(B$3:AF$3="T"))
AH4=SUMMENPRODUKT((WOCHENTAG(B$2:AF$2;2)>5)*(B$3:AF$3="N"))

Gruß,
Beate

Anzeige
AW: Bestimmte Einträge filtern
01.03.2008 17:52:29
Josef
Hallo Erwin,
meinst du so?
Tabelle2

 ABCDEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAFAGAHAIAJAK
1                                     
2 DiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDo     
3 01020304050607080910111213141516171819202122232425262728293031TNkT WEN WE
4Name 1TN T     T N  T   TN  kk TN    64223
5Name 2                               00000
6Name 3                               00000
7Name 4                               00000
8Name 5                               00000
9Name 6                               00000
10Name 7                               00000
11Name 8                               00000
12Name 9                               00000
13Name 10                               00000

Formeln der Tabelle
ZelleFormel
AG4=ZÄHLENWENN($B4:$AF4;AG$3)
AH4=ZÄHLENWENN($B4:$AF4;AH$3)
AI4=ZÄHLENWENN($B4:$AF4;AI$3)
AJ4=SUMMENPRODUKT(($B4:$AF4=AG$3)*(WOCHENTAG($B$3:$AF$3;2)>5))
AK4=SUMMENPRODUKT(($B4:$AF4=AH$3)*(WOCHENTAG($B$3:$AF$3;2)>5))
Excel Tabellen im Web darstellen  Excel Jeanie HTML

Gruß Sepp



Anzeige
AW: Danke an Beate und Josef
01.03.2008 18:03:00
Erwin
Hallo Beate und Josef,
vielen Dank für eure Antworten, die sind natürlich um "ein ganzes Stück" besser!! Die Funktion SUMMENPRODUKT habe ich ehrlich gesagt noch nicht gekannt. Ich mach es so, wie ihr es beschrieben hat.
Danke noch mal für eure Bemühungen und
ein schönes Wochende
Erwin aus Bayern

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige