Microsoft Excel

Herbers Excel/VBA-Archiv

Stückliste

Betrifft: Stückliste von: Thomas
Geschrieben am: 26.06.2008 10:34:19

Hallo Miteinander

Ich bin neu hier, aber über die Suche leider nur ansatzweise eine Lösung gefunden für mein Problem.

Ich möchte eine Stückliste in Tabelle1 eintragen. Eine weitere Stückliste in Tabelle2 usw.
Nun soll Excel in allen Tabellen nach gleichen Artikelnummern suchen. Bei gleichen Artikelnummern innerhalb der gleichen Tabelle oder in anderen Tabellen soll es von allen Artikeln die Summe addieren und dies auf einer weiteren Tabelle ausgeben.
Habe etwas mit SUMMEWENN probiert "=SUMMEWENN($F$6:$F$290;$F15;$J$6:$J$189)" suche in der Liste nach der Selben artikelnummer, wenn ja, addiere die Anzahl der Artikel.
Nun habe ich aber das addierte Ergebnis bei allen gleichen Artikeln und die suche läuft noch nicht über mehere Tabellen......

Hoffe ihr versteht was ich hier gerne möchte.

Danke für eure Hilfe.

  

Betrifft: ein 3D-SUMMEWENN() ... von: neopa
Geschrieben am: 26.06.2008 10:38:16

Hallo Thomas,

... dazu sieh mal hier: http://www.excelformeln.de/formeln.html?welcher=342

Gruß werner
.. , - ...


  

Betrifft: AW: Stückliste von: hary
Geschrieben am: 26.06.2008 10:40:37

Hallo Thomas
hinter deiner Formel zusetzen. zb. (also die betreffende Tabelle)


+summewenn(Tabelle2!B6:B15)


Gruss Hary


  

Betrifft: AW: Stückliste von: Thomas
Geschrieben am: 26.06.2008 14:57:11

Hallo Werner

Vielen Dank für deine rasche Antwort ! Sieht etwas komliziert aus, hoffe ich komme klar damit.
Werde ich mal ausprobieren.

Danke und Gruss
Thomas


  

Betrifft: AW: Stückliste von: Thomas
Geschrieben am: 26.06.2008 17:03:23

Hallo nochmal, sorry ich habe es nicht wirklich hinbekommen, verstehe die angegebenen Formeln etwas zu wenig....

Habe mal eine Beispiel hochgeladen: https://www.herber.de/bbs/user/53381.xls

Kurze erklärung: In Budget wird die gesamte geplante Menge eingegeben.
In Spalte "A" wird die addierte Stückzahl angezeigt, diese soll aber nur einmal angezeigt werden.....
Unter Stk. ist die Anzahl Teile pro Baugruppe gemeint.
Materialbedarf ist die Addition aus Budget und der Totalen Anzahl Teile der Baugruppe.

Vielen Dank für Eure Hilfe !
Gruss Thomas


  

Betrifft: sorry, ... von: neopa
Geschrieben am: 26.06.2008 19:20:57

Hallo Thomas,

... wenn Du die Formeln aus excelformeln. de meinst, da komme ich heut und morgen wahrscheinlich nicht dazu, deshalb habe ich auch die Frage offen gestellt.

Wenn Du aber nur den richtigen Syntax zu SUMMEWENN() meinst, dann sieh auch mal hier: http://www.online-excel.de/excel/singsel.php?f=15


Gruß Werner
.. , - ...


  

Betrifft: AW: Diese Formel in Blatt 3 von: hary
Geschrieben am: 26.06.2008 22:03:29

Hallo Thomas
Setze diese Formel mal Tabelle 3 rein,gezaehlt wird Nr. 1402200532


=SUMMEWENN(Tabelle1!F7:F15;Tabelle1!F8;Tabelle1!J7:J15)+SUMMEWENN(Tabelle2!F7:F15;Tabelle2!F8; _
Tabelle2!J7:J15)


Gruss Hary


  

Betrifft: AW: Diese Formel in Blatt 3 von: Thomas
Geschrieben am: 27.06.2008 13:59:48

Hallo Hary und Werner

Vielen Dank für Eure Hilfe ! Das ist genau die Formel, die ich gesucht hatte. Werde nun meine Tabellen mit den Stücklisten entsprechend ergänzen und testen.

Gruss Thomas