Microsoft Excel

Herbers Excel/VBA-Archiv

Probleme mit zeitberechnung | Herbers Excel-Forum


Betrifft: Probleme mit zeitberechnung von: Rupert Föderler
Geschrieben am: 16.10.2008 09:54:46

Hallo Forum,

ich habe da ein problem mit der zeitberechnung, in der liste im anhang sieht man wie ich zeitdaten aus dem system bekomme (4:48 = 4 minuten 48 sekunden) oder :07 = 7 sekunden, und leider auch 62:44 was dann 1 stunde, 2 minuten, 44 Sekunden sind) leider weiss ich nicht, wie ich das jetzt auf das format HH:MM:SS umwandeln könnte.

Hoffe es hat jemand von euch eine Idee

danke vorab

https://www.herber.de/bbs/user/56053.xls

  

Betrifft: AW: Probleme mit zeitberechnung von: Beverly
Geschrieben am: 16.10.2008 10:28:19

Hi Rupert,

vielleicht so:

Tabellenblattname: Tabelle1

 

A

B

1

4:48

00:04:48

2

:07

00:00:07

3

4:31

00:04:31

4

38:38

00:38:38

5

2:03

00:02:03

6

:54

00:00:54

7

2:23

00:02:23

8

54:55

00:54:55

9

5:36

00:05:36

10

:15

00:00:15

11

1:07

00:01:07

12

1:39

00:01:39

13

1:09

00:01:09

14

:21

00:00:21

15

8:01

00:08:01

16

1:52

00:01:52

17

:06

00:00:06

18

1:35

00:01:35

19

5:15

00:05:15

20

:26

00:00:26

21

3:26

00:03:26

22

41:20

00:41:20

23

32:44

00:32:44

24

62:44

01:02:44


Benutzte Formeln:
B1: =((WENN(ISTFEHLER(LINKS(A1;FINDEN(":";GLÄTTEN(A1))-GLÄTTEN(A1)));0;(LINKS(A1;FINDEN(":";A1)-1)*1))+RECHTS(A1;LÄNGE(A1)-FINDEN(":";A1))*1/60))/60/24



GrußformelBeverly's Excel - Inn


  

Betrifft: AW: Probleme mit zeitberechnung von: Rupert Föderler
Geschrieben am: 16.10.2008 10:33:25

Hallo Karin (Beverly)

Genau so, herzlichen dank für deine Hilfe

LG
Rupert


  

Betrifft: AW: Probleme mit zeitberechnung von: Rupert Föderler
Geschrieben am: 16.10.2008 11:29:25

Hallo,

Ja, das funktioniert, jedoch sobald die Zahl 72:00 übersteigt, hat er ein falsches ergebnis und fängt mit 00:00:01 (bei 72:01) wieder an (es kann auch vorkommen das werte über hundert in der liste sind)

Wenn du dafür vielleicht auch noch eine Lösung hättest wäre das super.

LG
Rupert


  

Betrifft: AW: Probleme mit zeitberechnung von: David
Geschrieben am: 16.10.2008 11:37:39

Hallo Rupert,

mein Vorschlag funzt auch bei 3 und mehrstelligen Zeitangaben.

Gruß
David


  

Betrifft: AW: Probleme mit zeitberechnung von: Beverly
Geschrieben am: 16.10.2008 12:25:15

Hi Rupert,

=WENN(ISTFEHLER(GLÄTTEN(A1)*1);RECHTS(GLÄTTEN(A1);2)/87840;GLÄTTEN(A1)/60)


GrußformelBeverly's Excel - Inn


  

Betrifft: AW: Probleme mit zeitberechnung von: David
Geschrieben am: 16.10.2008 10:34:37

Hallo Rupert,

deine Daten bestehen aus Text, deswegen ist es etwas umständlicher:

=WENN(ISTFEHLER(LINKS(GLÄTTEN(A1);SUCHEN(":";GLÄTTEN(A1);1)-1)*1);0;LINKS(GLÄTTEN(A1);SUCHEN(":"; GLÄTTEN(A1);1)-1))/1440+RECHTS(GLÄTTEN(A1);2) /86400

und dann formatieren: hh:mm:ss

Das sollte dein Problem lösen.

Gruß
David


  

Betrifft: @David & Beverly von: Rupert Föderler
Geschrieben am: 16.10.2008 13:17:31

Herzlichen Dank für eure Hilfe, Ihr habt mich vor viel arbeit bewahrt.

LG
Rupert


Beiträge aus den Excel-Beispielen zum Thema "Probleme mit zeitberechnung"