Microsoft Excel

Herbers Excel/VBA-Archiv

Geburtstag | Herbers Excel-Forum


Betrifft: Geburtstag von: Jan Richters
Geschrieben am: 16.10.2008 10:07:49

Guten Morgen

Wie errechne ich den nächsten Geburtstag in Tagen. Die Schaltjahre müssen mit beachtet werden!!
Wer hat eine Idee?

Gruß Jan

  

Betrifft: AW: Geburtstag von: Hajo_Zi
Geschrieben am: 16.10.2008 10:14:14

Hallo Jan,

=Geburstag-Heute() vielleicht noch +1

GrußformelHomepage


  

Betrifft: AW: Geburtstag von: Jan Richters
Geschrieben am: 16.10.2008 10:20:57

Moin Hajo

danke für deine Antwort, aber du hast mich falsch verstanden.
Ich bin auf der Suche nach einer Formel die mir den nächsten Geburtstag in Tagen ausrechnet und das Schaltjahr mit beachtet. Nicht nur einmalig sondern die Formel muss auch im nächsten (und alle folgenden Jahre) passen.


  

Betrifft: AW: Geburtstag von: Hajo_Zi
Geschrieben am: 16.10.2008 10:38:22

Hallo Jan,

es gibt wohl einfachere Lösungen. Aber ich bin nicht der Formelmensch.

 AB
1Geburtstagin Tagen
212.01.20082
323.02.2008 
425.05.2008 
523.09.2008 
617.10.1959 
719.10.2008 

Formeln der Tabelle
ZelleFormel
B2{=DATUM(JAHR(HEUTE()); MONAT(MIN(WENN(DATUM(JAHR(HEUTE()); MONAT(A2:A7); TAG(A2:A7))>HEUTE(); A2:A7))); TAG(MIN(WENN(DATUM(JAHR(HEUTE()); MONAT(A2:A7); TAG(A2:A7))>HEUTE(); A2:A7))))-HEUTE()+1}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Hajo


  

Betrifft: AW: Geburtstag von: David
Geschrieben am: 16.10.2008 11:34:20

Hallo Jan,

Geburtstag steht in A1:

=WENN(HEUTE()-DATUM(JAHR(HEUTE());MONAT(A1);TAG(A1))>0;DATUM(JAHR(HEUTE())+1;
MONAT(A1);TAG(A1))-HEUTE();DATUM(JAHR(HEUTE());MONAT(A1);TAG(A1))-HEUTE())



Gruß
David


Beiträge aus den Excel-Beispielen zum Thema "Geburtstag"