Microsoft Excel

Herbers Excel/VBA-Archiv

Listen aufbereiten | Herbers Excel-Forum


Betrifft: Listen aufbereiten von: Mathias
Geschrieben am: 16.10.2008 10:26:43

Hallo,

hier die Beispieldatei:

https://www.herber.de/bbs/user/56055.xls

Ich möchte nun die zwei Spalten (A + B) mit Eingaben so aufbereiten,
dass das Ergebnis wie in den Spalten C und D dabei herauskommt.

Das ganze möglichst *nicht* mit VBA, sondern über Formeln in den Spalten C und D.

Bin für jegliche Hinweise dankbar.

Viele Grüße

Mathias

  

Betrifft: AW: Listen aufbereiten von: Rudi Maintaire
Geschrieben am: 16.10.2008 10:47:24

Hallo,
siehe hier: http://www.excelformeln.de/formeln.html?welcher=160

Gruß
Rudi


  

Betrifft: AW: Listen aufbereiten von: Mathias
Geschrieben am: 16.10.2008 10:58:24

Hallo Rudi,

danke für den Tipp. Funktioniert bestens.

Jetzt suche ich nur noch eine Lösung für Spalte D:

Alle Zellen aus Spalte A auflisten, die nicht leer sind und wo *kein* "x" daneben in Spalte B steht.

Viele Grüße

Mathias


  

Betrifft: AW: Listen aufbereiten von: David
Geschrieben am: 16.10.2008 11:02:52

Hallo Matthias,

so sollte es gehen:

=INDEX(A:A;KKLEINSTE(WENN($B$2:$B$10="x";"";WENN($A$2:$A$10="";"";ZEILE($A$2:$A$10)));ZEILE(A1)))

Rückmeldung wäre nett.

Gruß
David


  

Betrifft: AW: Listen aufbereiten von: Mathias
Geschrieben am: 16.10.2008 12:11:47

Hallo,


danke für die Tipps!

Meine Lösung sieht jetzt wie folgt aus:

https://www.herber.de/bbs/user/56057.xls

Was jetzt eigentlich nur noch stört ist die "#ZAHL!"-Fehlermeldung.

Kann man die irgendwie loswerden oder noch besser in der Dropdown-Liste (F1 und G1) rechts ausfiltern?

Ideal wäre, wenn in der Gültigkeitsprüfung der Listenbereich automatisch auf die tatsächlich verwendete Länge beschränkt werden könnte. Ich hoffe ich hab mich verständlich ausgedrückt ;-)

Viele Grüße

Mathias


  

Betrifft: AW: Listen aufbereiten von: Bertram
Geschrieben am: 16.10.2008 12:38:40

Hallo Mathias,

am Einfachsten geht's mit der Formel =WENN(ISTFEHLER(deine Formel);"";deine Formel)

(allerdings hast du dann Leerzellen in der Gültigkeit) oder mit der Gültigkeit für z.B. Liste 1

=BEREICH.VERSCHIEBEN($C$2;;;ANZAHL2(C:C)-SUMMENPRODUKT(--ISTFEHLER($C$2:$C$10))-1)

Gruß
Bertram


  

Betrifft: Nachtrag von: Bertram
Geschrieben am: 16.10.2008 12:49:20

Falls du die Fehlerwerte mit WENN(...) ausblendest, dann lautet die Gültigkeit z.B.

=BEREICH.VERSCHIEBEN($C$2;;;(SUMME(--($C$1:$C$10<>""))-1))

Gruß
Bertram


  

Betrifft: ERLEDIGT AW: Listen aufbereiten von: Mathias
Geschrieben am: 16.10.2008 12:52:31

Hallo Bertram,

die Lösung mit der Formel in der Gültigkeitsprüfung ist perfekt!!! :-)

Ich danke nochmal allen ganz herzlich für die tollen Tipps.

Ohne eure Hilfe hätte ich sicher noch stundenlang daran rumgebastelt.

Viele Grüße

Mathias


  

Betrifft: NACHTRAG: Listen aufbereiten von: Mathias
Geschrieben am: 19.10.2008 09:57:22

Hallo,

hab jetzt leider feststellen müssen, dass die Formeln nicht in freigegebenen Dateien funktionieren, zumindest nicht zusammen mit der Gültigkeitsprüfung...

Fehlermeldung: "Ein Array kann in freigegebenen Dateien nicht kopiert oder verschoben werden"

Falls jemand noch ´ne Idee hat... ;-)

Viele Grüße

Mathias


Beiträge aus den Excel-Beispielen zum Thema "Listen aufbereiten"