Microsoft Excel

Herbers Excel/VBA-Archiv

Problem mit Summierung | Herbers Excel-Forum


Betrifft: Problem mit Summierung von: Stefan
Geschrieben am: 02.12.2009 11:17:11

Hallo zusammen,

ich habe ein Problem mit einer Summierung. Ich habe eine Kalkulation, die 1500 Zeilen lang ist. Ich möchte jetzt eine Summierung aus allen 6 Zeilen vornehmen, also in der Zelle B9 soll die Summe aus =U9+U15+U21+...... bis zur letzten Zeile erfolgen, also alle 6 Zeilen. Das Problem ist, bei der normalen Eingabe ist bei Zelle 1209 Schluss, er sagt dann "Formel zu lang". Wie kann ich das Problem lösen ohne x Zwischensummenfelder zu bilden ?

Danke schon mal im Voraus und Gruß
Stefan

  

Betrifft: AW: Problem mit Summierung von: David
Geschrieben am: 02.12.2009 11:22:02

Hallo Stefan,

vielleicht so?

Tabelle1

 ABCD
1Zeile 1831   
2Zeile 2429   
3Zeile 319   
4Zeile 4837   
5Zeile 5915   
6Zeile 6787787 
7Zeile 7218   
8Zeile 8358   
9Zeile 9742   
10Zeile 10476   
11Zeile 11767   
12Zeile 12181181 
13Zeile 13869   
14Zeile 14784   
15Zeile 15842   
16Zeile 16672   
17Zeile 17218   
18Zeile 18341341 
19Zeile 19385   
20Zeile 20443   
21Zeile 2126   
22Zeile 22272   
23Zeile 23314   
24Zeile 24948948 
25Zeile 25642   
26Zeile 26896   
27Zeile 2714   
28Zeile 28825   
29Zeile 29614   
30Zeile 30122122 
31  157872379--> nur zur Kontrolle
32       
33  2379   

verwendete Formeln
Zelle Formel
C6 =B6
C12 =B12
C18 =B18
C24 =B24
C30 =B30
B31 =SUMME(B1:B30)
C31 =SUMME(C1:C30)
B33 {=SUMME(WENN(ZEILE(B1:B30)/6=GANZZAHL(ZEILE(B1:B30)/6);B1:B30;0))}
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 4.11

Gruß
David


  

Betrifft: AW: Problem mit Summierung von: Stefan
Geschrieben am: 02.12.2009 11:33:37

Hallo David, nein. Ich machs mal an einem Beispiel einer kurzen Tabelle:

in Spalte C9 soll die Summe stehen von U9+U15+U21+U26
In Zelle C10 soll die SUmme stehen von U10+U16+U21+U27 usw...

Das ist ja manuell einfach zu lösen, aber die Summierung geht bis ca. Zeile 1500 und da ist dann bei 1209 Schluss weil die Formel zu groß ist...

Verstehste ?


  

Betrifft: AW: Ich habe die Lösung von: Stefan
Geschrieben am: 02.12.2009 12:02:51

mit "SUMMEWENN":

=SUMMEWENN(B9:U1490;B15;U9:U1490)

in B15 steht der Bereich den er summieren sollte, also B15 ist quasi der Filter, er summiert jetzt nur die Felder in denen der Wert von B15 steht, genau das was ich wollte.

Gruß
Stefan


  

Betrifft: AW: Ich habe die Lösung von: David
Geschrieben am: 02.12.2009 13:00:53

das passt zwar überhaupt nicht zu deiner Beschreibung, aber wenn du damit glücklich bist...

Gruß
David


Beiträge aus den Excel-Beispielen zum Thema "Problem mit Summierung"