Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema CommandButton
BildScreenshot zu CommandButton CommandButton-Seite mit Beispielarbeitsmappe aufrufen

Selection, bin ich BLÖD ? | Herbers Excel-Forum


Betrifft: Selection, bin ich BLÖD ? von: walli
Geschrieben am: 02.12.2009 12:20:45

Hallo allerseits,
habe folgende Zeile vom Forum erhalten.

Private Sub CommandButton22_Click()
ActiveSheet.Range("R6:R" & Cells(Rows.Count, 1).End(xlUp).Row).Select
End Sub

In der Tabelle einwandfrei.

Wenn ich aus einer anderen Tabelle dies ausführe:
Private Sub CommandButton31_Click()
    Sheets("Liste").Select
ActiveSheet.Range("R6:R" & Cells(Rows.Count, 1).End(xlUp).Row).Select
Exit Sub

wird die Zelle R1 bis R6 selectiert, WIESO ?

mfg Walli


  

Betrifft: AW: Selection, bin ich BLÖD ? von: Tino
Geschrieben am: 02.12.2009 12:33:49

Hallo,
der Code steht wahrscheinlich in einer anderen Tabelle und somit bezieht sich
Cells(Rows.Count, 1).End(xlUp).Row auf diese wo sich der Code befindet.

Versuche es mal so.

With Sheets("Liste")
.Select
ActiveSheet.Range("R6:R" & .Cells(.Rows.Count, 1).End(xlUp).Row).Select
End With

Gruß Tino


  

Betrifft: Danke Tino, so geht es ! --)) von: walli
Geschrieben am: 02.12.2009 12:46:28




  

Betrifft: Tino habe noch eine Frage von: walli
Geschrieben am: 02.12.2009 14:16:34

Hallo Tino,
habe noch eine Frage.
Ich möchte gern die Zahlenwerte der Spalte "I" die als Text formatiert sind
über eine Verweis Funktion abfragen, leider auch ohne Erfolg.
Der Wert bzw Name soll in Spalte K reingesetzt werden.
=WVERWEIS(I12;$AB$12:$AD$96;1)
mfg walli


  

Betrifft: weis jetzt nicht was Du meinst? ... von: Tino
Geschrieben am: 02.12.2009 14:55:54

Hallo,
vielleicht so?

 IJKABACAD
11Suchwert FormelMatrix als Text
1232 32313233

Formeln der Tabelle
ZelleFormel
K12=WVERWEIS(I12;$AB$12:$AD$96;1)


Gruß Tino


  

Betrifft: AVielleicht schicke ein Muster von: walli
Geschrieben am: 02.12.2009 15:08:04

Hallo Tino,
habe gerade in der Firma viel zu tun,
vielleicht schicke ich ein Muster.
Bei mir immer der letzte Name aus der Matrix angezeigt.
Habe mal SVerweis genommen, ebenfalls.

mfg walli


  

Betrifft: Muster wäre gut, aber ... von: Tino
Geschrieben am: 02.12.2009 15:37:59

Hallo,

WVERWEIS sucht in der ersten Zeile der Matrix
SVERWEIS sucht in der ersten Spalte der Matrix.

Bei mir ist es WVERWEIS weil ich in der ersten Zeile suchen will, die erste Zeile ist demnach AB12 bis AD12.

Würde ich SVERWEIS verwenden, wird in der ersten Spalte gesucht also AB12 bis AB96


Gruß Tino


  

Betrifft: Guten Abend Tino -) von: walli
Geschrieben am: 02.12.2009 22:07:03

Guten Abend Tino,
Sverweis, klappt jetzt, dank für die
Hilfe.
gruß walli