Microsoft Excel

Herbers Excel/VBA-Archiv

Zirkelbezug | Herbers Excel-Forum


Betrifft: Zirkelbezug von: Roger
Geschrieben am: 08.01.2010 14:49:31

Hallo zusammen

Hab folgendes Problem. Wenn ich sage er soll in Zelle J4 nur P4+S4 rechnen wenn M9 über 100 ist sonst soll er mir nur P4 rechnen. Die Zeilen 1-3 sind fix. Ab Zeile 4 werden laufend neue Zeilen eingefügt, also sollte die Formel auch mitwandern können.

Wenn ich in J4 folgende Formel eingebe macht er mir einen Zirkelbezug:
=WENN(M9>100;P4;P4+S4)

Wie kann ich das umgehen?

https://www.herber.de/bbs/user/67081.xls

Besten Dank für eure Hilfe
Gruss Roger

  

Betrifft: AW: Zirkelbezug von: Matze
Geschrieben am: 08.01.2010 15:18:58

Hi Roger,

bin nicht sicher ob ich Dich richtig verstehe.
Standart ist das Excel relative Bezüge verwendet und somit Deine Formel sich auch beim kopieren oder Zellen einfügen anpassen.

Möchtest Du jedoch eine Zelle Festnagel, dann geht das mit festen Bezügen.
Dazu verwendet man das $ Zeichen.
Z.B.
=WENN($M$9>100;P4;P4+S4)

Du kannst mit der F4 Tase während Du eine Formel schreibst zwischen den Bezugsarten wechseln.
A1 = Relativer Bezug in Spalten und Zeilen
$A1 = Festerbezug auf Spalte und relativer Bezug auf die Zeile

Hoffe das ich Dir helfen konnte.

Gruß, Matze.


  

Betrifft: AW: Zirkelbezug von: Roger
Geschrieben am: 08.01.2010 15:32:30

Hallo matze

Das mit den $Zeichen ist mir klar. Es geht mir um den Zirkelbezug der entsteht. Das andere hab ich nur geschrieben damit klar ist das die jetzige Zeile 4 immer weiter nach unten wandert.

Gruss
Roger


  

Betrifft: AW: Zirkelbezug von: Matze
Geschrieben am: 08.01.2010 15:50:48

Hi Roger,

unter xl2007 kam es nicht zum Zirkelbezug.

Bei 2003 konnte ich das nachvollziehen.

Schalte mal Extras/Optionen/Berechnung/Iteration ein - Den Haken setzten.

Gruß, Matze.


  

Betrifft: AW: Zirkelbezug von: Roger
Geschrieben am: 08.01.2010 16:30:50

Hallo Matze

Ich habs mal ausprobiert. Leider geht dann die Formel nur halb. Es rechnet zwar wenn M9 unter 100 ist nur P4 dazu, wenn aber M9 über 100 ist rechnet er nicht P4+S4 mit dieser Formel
=WENN(M9>100;P4;P4+S4)

Was ist Falsch? Und muss das mit der Iteration sein? Da ich die Tabelle nicht alleine benutze müssten die ja dann alle auch einschalten.

Gruss Roger


  

Betrifft: AW: Zirkelbezug von: Roger Berchtold
Geschrieben am: 08.01.2010 18:59:57

Hallo Matze

Ich habs mal ausprobiert. Leider geht dann die Formel nur halb. Es rechnet zwar wenn M9 unter 100 ist nur P4 dazu, wenn aber M9 über 100 ist rechnet er nicht P4+S4 mit dieser Formel
=WENN(M9>100;P4;P4+S4)

Dazu muss ich sagen das M9 im laufe der eingaben über 100 kommen kann dann müsste es also wenn es soweit ist wieder rechnen P4+S4. Also laufend überprüfen. Wenn das irgendwie möglich ist.

Was ist Falsch? Und muss das mit der Iteration sein? Da ich die Tabelle nicht alleine benutze müssten die ja dann alle auch einschalten.

Gruss Roger


  

Betrifft: AW: Zirkelbezug von: Roger
Geschrieben am: 10.01.2010 10:58:57

hat sich erledigt. Mache es jetz tmit einem Makro am schluss von Hand. Das ist einfacher.
Gruss
Roger