Microsoft Excel

Herbers Excel/VBA-Archiv

Rowfield FIX, Datafield DYN bei PT möglich ? | Herbers Excel-Forum


Betrifft: Rowfield FIX, Datafield DYN bei PT möglich ? von: Zacharias
Geschrieben am: 19.01.2010 08:56:19

Hallo Zusammen,

ich hätte eine Frage bezgl. der Zeilen- oder Spaltenfelder von Pivottabellen:

Über ein Jahr verteilt treten in den 12 Monaten verschiedene Ereignisse auf,
deren Häufigkeit ich im jeweiligen Monat summieren und darstellen will.
Diese Ereignisse müssen aber NICHT jeden Monat auftreten.
In der Datenquelle existiert ein Spalte "Monat", in welcher der jeweilige Monat
eingetragen wird in dem das Ereignis stattfindet.

Bei Zuweisung dieser Spalte als Row- oder Columnfield (und als Datafield)
ergibt sich erwartungsgemäß eine Tabelle die nur die Monate enthält in denen
Ereignisse stattfinden.

Nun die Frage:
Ist es möglich alle 12 Monate als Row- oder Columnfield anzugeben (per array) und
die Ereignisse selbst als Datafield anhand der Datenquell-Spalte "Monat" ?
Die Pivottabelle und das darauf basierende Chart sollen nämlich immer die gleiche Anzahl von
Monaten haben, denen dann (bei eingetretenem Ereignis) die Ereignisse zugeordnet werden.
Monate ohne Ereignisse sollen eben auch vorhanden sein, wenn auch mit der Summe 0.

Ich bin Euch für jeden Hinweis dankbar !

Viele Grüße
Zacharias

P.S. ich komme erst heute Abend zum Lesen von evt. Antworten
- Soll also nicht unhöflich sein, wenn ich mich erst später bedanken kann !

  

Betrifft: AW: Rowfield FIX, Datafield DYN bei PT möglich ? von: fcs
Geschrieben am: 19.01.2010 17:19:23

Hallo Zacharias,

Pivots können nur auswerten und ausgeben was da ist.

auf den 1. Blick sehe ich folgende Möglichkeit:

Per Formel die Daten für das Diagramm aus dem Pivotpericht lutschen, wobei die Monate fest vorgegeben werden und Daten per Funktion PIVOTDATENZUORDNEN

=WENN(ISTFEHLER(PIVOTDATENZUORDNEN("Anzahl von Monat";$A$3;"Monat";Q4));0;
PIVOTDATENZUORDNEN("Anzahl von Monat";$A$3;"Monat";Q4))

In Q4 steht dann z.B. 1 für den 1. Monat

Gruß
Franz



  

Betrifft: AW: Rowfield FIX, Datafield DYN bei PT möglich ? von: fcs
Geschrieben am: 19.01.2010 17:19:44

Hallo Zacharias,

Pivots können nur auswerten und ausgeben was da ist.

auf den 1. Blick sehe ich folgende Möglichkeit:

Per Formel die Daten für das Diagramm aus dem Pivotpericht lutschen, wobei die Monate fest vorgegeben werden und Daten per Funktion PIVOTDATENZUORDNEN

=WENN(ISTFEHLER(PIVOTDATENZUORDNEN("Anzahl von Monat";$A$3;"Monat";Q4));0;
PIVOTDATENZUORDNEN("Anzahl von Monat";$A$3;"Monat";Q4))

In Q4 steht dann z.B. 1 für den 1. Monat

Gruß
Franz



  

Betrifft: AW: Rowfield FIX, Datafield DYN bei PT möglich ? von: Zacharias
Geschrieben am: 19.01.2010 21:20:37

Hallo Franz,

Da hilft Du mir gleich wieder - ein Dank für Deine Hilfbereitschaft.

Ich denke damit komme ich weiter. Ich hatte zwar gehofft es gäbe einen direkten Weg,
aber ein kleiner Umweg über die PIVOTDATENZUORDNEN-Funktion ist immer noch wesentlich
besser als gleich auf die PT-Funktionalitäten (insbesondere die Einschränkungsmöglichkeiten)
zu verzichten. Ich habe gerade bei microsoft gelesen, daß statt der üblichen Worksheetfunctions
hier mit . GetData direkt eine passende Methode existiert (ActiveSheet.PivotTables(1).GetData(...)
Mit dieser müßte ich dann ja zur Laufzeit die notwendige Hilfstabelle aufbauen können

Da die PT wie gesagt dynamisch und daher variabel ist, werde ich versuchen mit ptTable.DataBodyRange.Rows.Count +1 die Startzeile für die Hilfstabelle zu ermitteln.
Werde morgen mal mein Glück versuchen.

Auf jeden Fall nochmal herzlichen Dank speziell für Deine erneute Hilfe
und allgemein ein Dank an Herber und all die hilfsbereiten Leute hier.

Ich weiß noch wie langwierig und anstrengend solche Informationsbeschaffung im VOR-Internetzeitalter war - Baujahr 1966 ; - ) - da bin ich manchmal wochenlang nicht weitergekommen.

Viele Grüße
Zacharias


Beiträge aus den Excel-Beispielen zum Thema "Rowfield FIX, Datafield DYN bei PT möglich ?"