Microsoft Excel

Herbers Excel/VBA-Archiv

gewichteter Durchschnittspreis | Herbers Excel-Forum


Betrifft: gewichteter Durchschnittspreis von: Willi Willi
Geschrieben am: 25.01.2010 23:21:54

Hallo,

in meiner Tabelle möchte ich einen gewichteten Durchschnittspreis ermitteln mit 2 Bedingungen!

Beschreibe die Formeln mal mit eigenen Worten:

Zeile2: Wenn C2=Sorte1 und A2=Z dann F2/D2
Zeile3: Wenn C2:C3=Sorte1 und A2:A3=Z dann Summe(F2:F3)/Summe(D2:D3)
Zeile4: Wenn C2:C4=Sorte1 und A2:A4=Z dann Summe(F2:F4)/Summe(D2:D4)
usw.

Das Gleiche soll natürlich auch berechnet werden wenn sich die Art in A ändert oder die Bezeichnung in Sorte2 ändert.

Meine errechneten Ergebnisse stehen in Spalte G, nur leider mit einer Formel die ich nicht runterkopieren kann.

Bitte um Rat

https://www.herber.de/bbs/user/67483.xls

  

Betrifft: AW: gewichteter Durchschnittspreis von: Erich G.
Geschrieben am: 25.01.2010 23:36:24

Hi Tobi,
die folgende Formel sollte es tun - und die kannst du nach unten kopieren:

=SUMMENPRODUKT((A$2:A2=A2)*(C$2:C2=C2)*F$2:F2)/SUMMENPRODUKT((A$2:A2=A2)*(C$2:C2=C2)*D$2:D2)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: gewichteter Durchschnittspreis von: Willi Willi
Geschrieben am: 25.01.2010 23:43:49

Funktioniert einwandfrei, Dank Dir!