Microsoft Excel

Herbers Excel/VBA-Archiv

Formelproblem | Herbers Excel-Forum


Betrifft: Formelproblem von: Leitz G.
Geschrieben am: 02.02.2010 17:25:45

Hallo!

Habe mit dieser Formel ein Problem wenn ich sie auf eine Formel beziehe.

Ich bilde die Summe aus Spalte R wenn.... (das funktioniert weil in Spalte R Fixwerte sind).
In Spalte R können aber auch Minus Werte oder eine Null enthalten sein die ich aber in meiner Formel immer mit dem Wert 1 addieren soll.
Jetzt hab ich mir gedacht ich mache eine neue Spalte T in der ich den Wert aus R anzeigen lasse wenn die Zahl ein Plus Wert ist und und wenn kleiner +1 eine 1.
Wenn ich nun meine Formel auf die Spalte T anstatt R beziehe gibt sie mir nur WERT aus.

Worann kann das liegen und wie könnte ich das lösen?

=(SUMMENPRODUKT('[Kaindl Bestand.xls]Gesamtbestand'!$R$3:$R$3000*('[Kaindl Bestand.xls]Gesamtbestand'!$F$3:$F$3000=$B5) *('[Kaindl Bestand.xls]Gesamtbestand'!$V$3:$V$3000='[Kaindl Bestand.xls]Gesamtbestand'!$V$1) *('[Kaindl Bestand.xls]Gesamtbestand'!$N$3:$N$3000=$A5)))

Bitte um Hilfe!

Gruß
Gerd S.

  

Betrifft: welche Formel verwendest du in T ? o.T. von: Josef Ehrensberger
Geschrieben am: 02.02.2010 17:28:58

Gruß Sepp



  

Betrifft: AW: welche Formel verwendest du in T ? o.T. von: Leitz G.
Geschrieben am: 02.02.2010 17:35:48

Hallo!

In Spalte T hab ich diese Formel stehen:


=WENN(UND($V3>0;$R3<>"");WENN($R3>0,9;$R3;1);WENN(UND($V3>0;$P3<>"");WENN($P3>0,9;$P3;1);""))

Gruß
Gerd S.


  

Betrifft: AW: welche Formel verwendest du in T ? o.T. von: Josef Ehrensberger
Geschrieben am: 02.02.2010 17:37:24

Hallo Gerd,


dann nimm das letzte "" raus und ersetze es duch 0



Gruß Sepp



  

Betrifft: Enthält Spalte T Texte/Leerzellen/Fehler ? _oT von: NoNet
Geschrieben am: 02.02.2010 17:29:05

_oT = "ohne Text"


  

Betrifft: AW: Enthält Spalte T Texte/Leerzellen/Fehler ? _oT von: Gerd S.
Geschrieben am: 02.02.2010 22:23:01

Hallo!

Nein nur Zahlen, es funktioniet mit Summewenn aber da hab ich zu wenig Argumente

=WENN(SUMMEWENN(Gesamtbestand!$F$3:$F$358;$A3;Gesamtbestand!$T$3:$T$358)=0;""; SUMMEWENN(Gesamtbestand!$F$3:$F$358;$A3;Gesamtbestand!$T$3:$T$358))

Das mit der Null statt "" funktioniert auch nicht, es bleibt Wert.

Gruß
Gerd S.


  

Betrifft: AW: Enthält Spalte T Texte/Leerzellen/Fehler ? _oT von: Josef Ehrensberger
Geschrieben am: 02.02.2010 22:33:37

Hallo Gerd,


dann lade doch eine abgespeckte Datei hoch wo dieses #WERT! auftritt.



Gruß Sepp



  

Betrifft: AW: Enthält Spalte T Texte/Leerzellen/Fehler ? _oT von: Gerd S.
Geschrieben am: 02.02.2010 22:40:54

Sorry!

Hab übersehen, daß ich auch noch Leerzeilen dazwischen hatte, jetzt funktionierts mit der Null !

Herzlichen Dank für die Hilfe

Gruß
Gerd