Microsoft Excel

Herbers Excel/VBA-Archiv

Text wie auch Zahlen wiedergeben | Herbers Excel-Forum


Betrifft: Text wie auch Zahlen wiedergeben von: Harald Haldenwang
Geschrieben am: 25.02.2010 14:10:38

Hallo zusammen,

folgendes Problem liegt vor:

B1= Eingabezelle

Spalte C ab C4 beinhaltet Artikelnummern die numerisch, wie auch alphanumerisch sind, z.B. 1328, 1960, 4845RAL, Z090, Set-3-101ZN5 usw..

mit folgender Formel funktioniert es:

D4=WENN($B$1<>"";WENN(ZÄHLENWENN(C4;$B$1&"*");SVERWEIS($B$1&"*";C4;1;);"");"")

aber nur die alphanumerischen.

D.h. wenn ich in B1=1328 einsetze, bleibt D4 leer. Wenn ich in B1=4845RAL einsetze, dann steht in D4=4845RAL.

Wie kann ich die Formel verändern, dass jeglicher Inhalt aus der jeweiligen Zelle in der Zielzelle wiedergegeben wird?

Gruß

Harald

  

Betrifft: AW: Text wie auch Zahlen wiedergeben von: David
Geschrieben am: 25.02.2010 14:14:23

Hallo Harald,

dein SVERWEIS beinhaltet keine Matrix, die dafür normalerweise notwendig ist, sondern nur eine einzelne Zelle. Das gleiche für ZÄHLENWENN, das ergibt mit nur einer Zelle auch keinen Sinn. Das kann nicht funktionieren.

Ladt ein Beispiel hoch.

Gruß
David


  

Betrifft: AW: Text wie auch Zahlen wiedergeben von: Harald Haldenwang
Geschrieben am: 25.02.2010 14:19:44

man kann die formel auch so schreiben

D4=WENN($B$1<>"";WENN(ZÄHLENWENN(C4:C4;$B$1&"*");SVERWEIS($B$1&"*";C4:C4;1;);"");"")

kommt aber auf selbe raus. Die Matrix ist nur die Zelle C4, beim runterkopieren ändert sie sich ja dann.

Ziel ist es jede Zelle wiederzugeben, die Bestandteile aus B1 hat.

Gruß

Harald


  

Betrifft: AW: Text wie auch Zahlen wiedergeben von: Matthias5
Geschrieben am: 25.02.2010 14:27:57

Hallo Harald,

wenn der Wert in C mit dem Eintrag in B1 beginnen muss, dann wie in Spalte D. Wenn der Eintrag irgendwo im Suchwert stehen kann, dann wie in Spalte E:

Tabelle1

 BCDE
11328     
2       
3       
4  132813281328
5  A1328B  A1328B

verwendete Formeln
Zelle Formel
D4 =WENN($B$1<>"";WENN(LINKS(C4;LÄNGE($B$1))=$B$1&"";C4;"");"")
E4 =WENN($B$1<>"";WENN(ISTZAHL(FINDEN($B$1;C4));C4;"");"")

Tabellendarstellung in Foren Version 4.8


Gruß,
Matthias


  

Betrifft: AW: Text wie auch Zahlen wiedergeben von: Harald Haldenwang
Geschrieben am: 25.02.2010 14:39:24

Vielen dank, die Formel ist super.

Gruß

Harald


  

Betrifft: AW: Text wie auch Zahlen wiedergeben von: David
Geschrieben am: 25.02.2010 14:38:44

Hallo Harald,

trotzdem ist SVERWEIS und ZÄHLENWENN hier übertrieben.

Was hältst du von der Variante:


Tabelle1

 BCD
132   
2     
3     
4  13281328
5  1960 
6  445RAL 
7  Z090 
8  Set-3-101ZN5 

verwendete Formeln
Zelle Formel
D4 =WENN($B$1<>"";WENN(LÄNGE(WECHSELN(C4;$B$1;""))<>LÄNGE(C4);C4;""))
D5 =WENN($B$1<>"";WENN(LÄNGE(WECHSELN(C5;$B$1;""))<>LÄNGE(C5);C5;""))
D6 =WENN($B$1<>"";WENN(LÄNGE(WECHSELN(C6;$B$1;""))<>LÄNGE(C6);C6;""))
D7 =WENN($B$1<>"";WENN(LÄNGE(WECHSELN(C7;$B$1;""))<>LÄNGE(C7);C7;""))
D8 =WENN($B$1<>"";WENN(LÄNGE(WECHSELN(C8;$B$1;""))<>LÄNGE(C8);C8;""))

Tabellendarstellung in Foren Version 4.11



Gruß
David


  

Betrifft: AW: Text wie auch Zahlen wiedergeben von: Harald Haldenwang
Geschrieben am: 25.02.2010 14:40:14

Danke, das werde ich auch testen.

Gruß

Harald


Beiträge aus den Excel-Beispielen zum Thema "Text wie auch Zahlen wiedergeben"