SVERWEIS



Excel-Version: 97
nach unten

Betrifft: SVERWEIS
von: Nora
Geschrieben am: 07.05.2002 - 12:56:16

Hi!

Ich habe zwei Dateien. In der einen sind mehrere Mappen. In jeder Mappe ist in der ersten Spalte ein String, der mit A5B***** anfängt, und in der Zweiten Spalte ist eine Zahl:

A__________B__________
A5B111_____10001
A5B112_____10202
A5B148_____10020
A5B234_____10030


so sind die Mappen (das sind 4 stück) aufgebaut. Der String kommt aber nicht in mehreren Mappen gleichzeitig vor, immer nur in einer.

Die zweite Datei sieht eigentlich genauso aus (hat aber nur eine Tabelle/Mappe und dort sind alle Strings vorhanden).Aber es fehlen die Zahlen in der Spalte B. Diese möchte ich nun mit SVERWEIS holen. Es muss also überprüft werden, in welcher Mappe der A5B-String steht, wenn er gefunden wurde, soll die Zahl (10***) übertragen werden.

Ist das irgendwie zu realisieren?
Nora

nach oben   nach unten

Re: SVERWEIS
von: Christian
Geschrieben am: 07.05.2002 - 13:25:04

Hi,

folgende etwas lange und verschachtelte Formel (einzutragen in die zweite Spalte der zweiten Mappe) bringt eine Lösung für dein Problem:

=WENN(ISTNV(SVERWEIS(A1;[Mappe1]Tabelle4!$A:$B;2;FALSCH));WENN(ISTNV(SVERWEIS(A1;[Mappe1]Tabelle3!$A:$B;2;FALSCH));
WENN(ISTNV(SVERWEIS(A1;[Mappe1]Tabelle2!$A:$B;2;FALSCH));SVERWEIS(A1;[Mappe1]Tabelle1!$A:$B;2;FALSCH);
SVERWEIS(A1;[Mappe1]Tabelle2!$A:$B;2;FALSCH));SVERWEIS(A1;[Mappe1]Tabelle3!$A:$B;2;FALSCH));
SVERWEIS(A1;[Mappe1]Tabelle4!$A:$B;2;FALSCH))

Mit einer wennn-dann-sonst Formel wird ein Vorhandensein des zu suchenden Wertes in einem Tabellenblatt überprüft, ansonsten wird in das nächchste Blatt gesprungen und dort nachgeschaut, usw. .

Gruß

Christian


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS"