Sverweis?



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Sverweis?
von: Nora
Geschrieben am: 15.05.2002 - 10:36:55

Hallo!

Ich habe ein riesiges Problem:

Ich habe zwei Spalten:
in der ersten werden Strings eingefügt

in der anderen steht folgender Code:
=WENN(A35="";"";WENN(ISTFEHLER(SVERWEIS(A35;'G:\EK\Bedarfsbündelung\[Materialbedarf.xls]Tabelle1'!$A:$H;8;0));0;SVERWEIS(A35;'G:\EK\Bedarfsbündelung\[Materialbedarf.xls]Tabelle1'!$A:$H;8;0)))

Wenn ich nun einen String in die erste Spalte einfüge, dann soll gleich der Befehl in der zweiten Spalte berechnet werden. Na eine Berechnung ist das ja nicht, es soll ja nur ein Betrag hergeholt werden.
Mein Problem ist nun, dass mir ein falscher Betrag gegeben wird, sobald ich den String einschreibe. Ich weiß nicht wo dieser Betrag herkommt. Ich muss dann immer noch einmal diese Zelle anklicken und enter drücken. Manchmal wird mir aber auch der richtige Wert übergeben.

Warum bekomme ich einen falchen Wert und wie kann ich das Problem lösen?

Nora

nach oben   nach unten

Re: Sverweis?
von: Frank
Geschrieben am: 15.05.2002 - 10:54:05

Hallo Nora,

sind die Werte nach denen per Sverweis in Tabelle 1 in der Datei Materialbedarf aufsteigend sortiert? Wenn nicht solltest Du das mal probieren.

Gruß Frank


nach oben   nach unten

Re: Sverweis?
von: Nora
Geschrieben am: 15.05.2002 - 10:58:27

Hi Frank,
die Werte in Materialbedarf sind sortiert. Aufsteigend sortiert.
Gibt es noch eine ander Lösung?
Nora

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Sverweis?"