ZÄHLENWENN



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: ZÄHLENWENN
von: th.heinrich
Geschrieben am: 24.05.2002 - 17:41:59

hallo excel Fans,

folgendes problem


MS Excel von th.heinrich
 ABCD
1grenzerte5,5-7,5 
2>grenzwert1=ZÄHLENWENN(B4:B6;">7,5")
3>grenzwert  =ZÄHLENWENN(B4:B6;>WERT(TEIL(B1;5;3)))
4  8,0 
5  6,0 
6  7,0 


warum funkt die 2. ZÄHLENWENN formel nicht.
hintergrund: die werte in B1 koennen sich aendern und die zeile > grenzwert soll dies erkennen.

schoenes w'ende wuenscht thomas

nach oben   nach unten

Re: ZÄHLENWENN
von: Philip
Geschrieben am: 24.05.2002 - 18:15:29

Vielleichzt deshalb ?

ZÄHLENWENN(B4:B6;">WERT(TEIL(B1;5;3))")

Gruß,
Philip

nach oben   nach unten

Re: ZÄHLENWENN
von: Rolf, Lgh.
Geschrieben am: 24.05.2002 - 18:23:02

Hallo Thomas,
die Tücke liegt im Detail:

MS Excel von Rolf, Lgh. an th.heinrich
 ABCDE
1grenzerte5,5-7,5   
2>grenzwert1=ZÄHLENWENN(B4:B6;">7,5")*1 
3>grenzwert1=ZÄHLENWENN(B4:B6;">"&WERT(TEIL(B1;5;3))) 
4   8 
5   6 
6   7 

Gruss Rolf

nach oben   nach unten

Re: ZÄHLENWENN
von: th.heinrich
Geschrieben am: 24.05.2002 - 19:17:56

danke Rolf,

die TÜCKE bin leider meistens ich.

wohin mit "..." und wann &.

warum hast Du in D2 *1 ergaenzt ?

gruss thomas


nach oben   nach unten

Re: ZÄHLENWENN
von: Rolf, Lgh.
Geschrieben am: 24.05.2002 - 19:53:18

> warum hast Du in D2 *1 ergaenzt?
beim Kopieren entstanden - Sorry! - ändert ja aber nichts am Ergebnis

> wohin mit "..." und wann &.
& verbindet zwei (oder mehrere) Zeichenfolgen wie die Funktion VERKETTEN
z. B.:

MS Excel von Rolf, Lgh. an th.heinrich
 ABCD
1VornameNachnameName
2OttoMeyerOtto_Meyer=A2&"_"&B2

">" und das Ergebnis von WERT(... mußte hier verkettet werden
Ich hoffe, dass ich es verständlich erklärt habe.
Gruss Rolf

nach oben   nach unten

">"&...
von: th.heinrich
Geschrieben am: 24.05.2002 - 22:04:16

guten abend Rolf,

ist dies so zuverstehen, dass ">" als mathemathischer OPERATOR gilt und & den text beruecksichtigt ?

danke fuer Deine muehe

thomas


nach oben   nach unten

Re: ">"&...
von: Rolf, Lgh.
Geschrieben am: 25.05.2002 - 10:59:42

Hier muß der Vergleichsoperator > und die Zahl 7,5 durch & zum Text >7,5 umformatiert werden. Die Formal funktioniert in diesem Fall auch, wenn das Ergebnis von TEIL(B1;5;3) nicht durch WERT(...) in eine Zahl umgewandelt wird:
=ZÄHLENWENN(B4:B6;">"&TEIL(B1;5;3))
nach oben   nach unten

danke Rolf fuer die erklaerung o.t.
von: th.heinrich
Geschrieben am: 25.05.2002 - 15:13:35

.

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Anwendung beenden aus Exel"