Microsoft Excel

Herbers Excel/VBA-Archiv

Summen | Herbers Excel-Forum


Betrifft: Summen von: Franz
Geschrieben am: 17.01.2012 09:31:27

Guten Morgen,
suche bitte eine Formel.
In Spalte A stehen sortiert Namen untereinander.
In Spalte C steht ja oder nein oder xxx drinnen.
In Spalte D steht eine Zahl.
Nun wollte ich in Spalte E beim letzten gleichen Namen eine Summe ziehen,
aber nur, wenn in C ja oder nein steht.

Grüsse
Franz

  

Betrifft: AW: Summen von: Reinhard
Geschrieben am: 17.01.2012 09:43:27

Hallo Franz,

Tabellenblatt: [Mappe1]!Tabelle1
   │ A │ B │   C  │  D │  E │
---┼---┼---┼------┼----┼----┼
 1 │ a │   │ ja   │  1 │    │
---┼---┼---┼------┼----┼----┼
 2 │ a │   │ nein │  2 │    │
---┼---┼---┼------┼----┼----┼
 3 │ a │   │ ja   │  3 │    │
---┼---┼---┼------┼----┼----┼
 4 │ a │   │ xxx  │  4 │    │
---┼---┼---┼------┼----┼----┼
 5 │ a │   │ ja   │  5 │ 11 │
---┼---┼---┼------┼----┼----┼
 6 │ b │   │ xxx  │  6 │    │
---┼---┼---┼------┼----┼----┼
 7 │ b │   │ ja   │  7 │    │
---┼---┼---┼------┼----┼----┼
 8 │ b │   │ nein │  8 │    │
---┼---┼---┼------┼----┼----┼
 9 │ b │   │ ja   │  9 │    │
---┼---┼---┼------┼----┼----┼
10 │ b │   │ xxx  │ 10 │    │
---┼---┼---┼------┼----┼----┼
11 │ b │   │ nein │ 11 │ 35 │
---┼---┼---┼------┼----┼----┼
12 │ c │   │ ja   │ 12 │    │
---┼---┼---┼------┼----┼----┼
13 │ c │   │ xxx  │ 13 │    │
---┼---┼---┼------┼----┼----┼
14 │ c │   │ ja   │ 14 │    │
---┼---┼---┼------┼----┼----┼
15 │ c │   │ xxx  │ 15 │    │
---┼---┼---┼------┼----┼----┼
16 │ c │   │ nein │ 16 │ 42 │
---┴---┴---┴------┴----┴----┴
Benutzte Formeln:
E1 : =WENN(A1=A2;"";SUMMENPRODUKT(($A$1:$A$100=A1)*($C$1:$C$100<>"xxx")*($D$1:$D$100)))
E2 : =WENN(A2=A3;"";SUMMENPRODUKT(($A$1:$A$100=A2)*($C$1:$C$100<>"xxx")*($D$1:$D$100)))
E3 : =WENN(A3=A4;"";SUMMENPRODUKT(($A$1:$A$100=A3)*($C$1:$C$100<>"xxx")*($D$1:$D$100)))
usw. in E

A1:E16
haben das Zahlenformat: Standard

Gruß
Reinhard


  

Betrifft: AW: Summen von: Franz
Geschrieben am: 17.01.2012 10:08:26

Hallo Reinhard,

vielen Dank für Deine Mühe!!!

Gruß
Franz


Beiträge aus den Excel-Beispielen zum Thema "Summen"