Microsoft Excel

Herbers Excel/VBA-Archiv

Aufschlüsselung einer Tabelle | Herbers Excel-Forum


Betrifft: Aufschlüsselung einer Tabelle von: Diana
Geschrieben am: 30.01.2012 10:08:06

Hallo Alle zu sammen!

Habe ein Problem ich habe 1 Arbeitsmappe mit 3 Blättern,

im 1.Blatt ist eine gesamt Übersicht zu sehen
im 2. und 3. Blatt soll das 1. Blatt aufgeschlüsselt werden.

z.B.:

1. Blatt:

0 A B C D E F G
1 7 Brav 6 5 1 2 4
2 7 Rar 5 1 3 2 8
3 6 Rar 1 3 4 5 7
4 5 Brav 2 5 7 6 1
5 4 Rar 3 2 8 1 3

Im 2.Blatt sollen alle Zeilen erscheinen in welchen auf dem 1.Blatt in Spalte B das Wort Rar erscheint.

im 3.Blatt sollen alle Zeilen erscheinen in welchen auf dem 1.Blatt in Spalte B das Wort Brav ist.

Ist dies Möglich und wenn ja wie?

Bin leider kein Genie in solchen Sachen und hoffe Sie können mir alle helfen.

Für eine baldige Antwort bedanke ich mich im Voraus!!

Mit freundlichen Grüßen
Diana

  

Betrifft: AW: Aufschlüsselung einer Tabelle von: Michael Patzak
Geschrieben am: 30.01.2012 10:35:15

Hallo Diana,

Du kannst Du auf dem zweiten und dritten Blatt einen SVerweis mit einer Bedingung erstellen:
Für das zweite Blatt =wenn(Seite1;Spalte B = "B"; dann SVerweis; sonst nichts ("")
Für das dritte Blatt =wenn(Seite1;Spalte B = "R"; dann SVerweis; sonst nichts ("")
Viele Grüße
Michael


  

Betrifft: benutze doch den Filter von: Matthias L
Geschrieben am: 30.01.2012 10:40:56

Hallo Diana

Für die erste Zeile habe ich mal eine Überschrift eingefügt. so lässt sich der Filter besser darstellen.
Nun nach Spalte(B) filtern und Kriterium wählen

Tabelle1

 ABCDEFG
1Wert1SuchtextWert2Wert3Wert4Wert5Wert6
37Rar51328
46Rar13457
64Rar32813


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Nun markierst Du die entsprechenden Zeilen (hier 3,4,6) und wählst mit der rechten Maustaste Kopieren
Wechsel in die Zieltabelle z.B. nach Tabelle2!A1 und wähle mit der rechten Maustaste Einfügen.


Analog machst Du das mit den anderen Texten

Tabelle1

 ABCDEFG
1Wert1SuchtextWert2Wert3Wert4Wert5Wert6
27Brav65124
55Brav25761


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Hier eben die Zeilen(2,5) markieren und in das andere Ziel kopieren z.B. nach Tabelle3!A1

Das sollte es dann schon gewesen sein.

Gruß Matthias


  

Betrifft: AW: Aufschlüsselung einer Tabelle von: Rudi Maintaire
Geschrieben am: 30.01.2012 10:42:42

Hallo,

 ABCDE
17Brav651
25Brav257

ZelleFormel
A1{=WENN(ZEILE()>ZÄHLENWENN(Tabelle1!$B$1:$B$100;"Brav");"";INDEX(Tabelle1!A$1:A$100;KKLEINSTE(WENN(Tabelle1!$B$1:$B$100="Brav";ZEILE($1:$99);"");ZEILE())))}
B1{=WENN(ZEILE()>ZÄHLENWENN(Tabelle1!$B$1:$B$100;"Brav");"";INDEX(Tabelle1!B$1:B$100;KKLEINSTE(WENN(Tabelle1!$B$1:$B$100="Brav";ZEILE($1:$99);"");ZEILE())))}
C1{=WENN(ZEILE()>ZÄHLENWENN(Tabelle1!$B$1:$B$100;"Brav");"";INDEX(Tabelle1!C$1:C$100;KKLEINSTE(WENN(Tabelle1!$B$1:$B$100="Brav";ZEILE($1:$99);"");ZEILE())))}
D1{=WENN(ZEILE()>ZÄHLENWENN(Tabelle1!$B$1:$B$100;"Brav");"";INDEX(Tabelle1!D$1:D$100;KKLEINSTE(WENN(Tabelle1!$B$1:$B$100="Brav";ZEILE($1:$99);"");ZEILE())))}
E1{=WENN(ZEILE()>ZÄHLENWENN(Tabelle1!$B$1:$B$100;"Brav");"";INDEX(Tabelle1!E$1:E$100;KKLEINSTE(WENN(Tabelle1!$B$1:$B$100="Brav";ZEILE($1:$99);"");ZEILE())))}
Achtung, Matrixformel!
Die geschweiften Klammern{} nicht eingeben,
sondern die Zelle mit
Shift + Strg + Enter
verlassen statt Enter alleine.


Analog Tabelle3 mit "Rar"
Gruß
Rudi


  

Betrifft: AW: Aufschlüsselung einer Tabelle von: Diana
Geschrieben am: 30.01.2012 19:20:23

Meine Formel würde wie folgt aussehen:



=wenn('personenbezogene Daten'!B="TÜ";'personenbezogene Daten TÜ'!;"")



jedoch wenn ich auf Enter drücke, kommt die Meldung die eingegebene Fromel hat einen Fehler und es wird auf die letzten beiden Anführungszeichen verwiesen.



Was mache ich falsch?



Arbeite im Geschäft mit 2003 und zu hause mit 2010 macht das einen Unterschied?



Liebe Grüße Diana


  

Betrifft: AW: Aufschlüsselung einer Tabelle von: Hajo_Zi
Geschrieben am: 30.01.2012 19:51:04

Hallo Diana,

nach B fehlt die Zahl und beim zweiten Ausdruck fehlt die Zelle.

GrußformelHomepage


Beiträge aus den Excel-Beispielen zum Thema "Aufschlüsselung einer Tabelle"