Dienstjahre errechnen



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Dienstjahre errechnen
von: Andreas
Geschrieben am: 02.06.2002 - 19:37:07

Liebe Leute,

habe ein Formelproblem bei dem ich auf eure Unterstützung hoffe:

Ich habe in der Reihe "F" jeweils das Eintrittsdatum jedes Mitabeiters eingeben. Um die Dienstjahre jeweils mit akutellem Datum zu errechnen habe ich folgende Formel erstellt, leider kommt z.B. als Ergebnis bei Eintritt 1999 und Heute ist 2002 als Ergebnis 1996.

Ich verwende die folgende Formel:
=WENN(JAHR(F5)=JAHR(HEUTE());1;(JAHR(HEUTE()-JAHR(F5))))

Hoffentlich könnt ihr mir helfen,

Vielen Dank und LG

Andreas

nach oben   nach unten

Re: Dienstjahre errechnen
von: Hajo
Geschrieben am: 02.06.2002 - 19:44:53

Hallo Andreas
verwende die die Funktion Datediff

278. Datumsdifferenz in Jahren
=DATEDIF(A1;HEUTE();"Y")
Differenz in Tagen: =DATEDIF(Anfangsdatum;Enddatum;"D")
Differenz in Monaten: =DATEDIF(Anfangsdatum;Enddatum;"M")
Differenz in Jahren: =DATEDIF(Anfangsdatum;Enddatum;"Y")
Differenz in Tagen im selben Jahr: =DATEDIF(Anfangsdatum;Enddatum;"YD")
Differenz in Monaten im selben Jahr: =DATEDIF(Anfangsdatum;Enddatum;"YM")
Differenz in Tagen im selben Jahr/Monat: =DATEDIF(Anfangsdatum;Enddatum;"MD")

Guß Hajo

nach oben   nach unten

Re: Dienstjahre errechnen
von: PeterW
Geschrieben am: 02.06.2002 - 19:57:13

Hallo Andreas,

mit der Formel:
=WENN(JAHR(F5)=JAHR(HEUTE());1;HEUTE()-F5)
klappt es - zumindest bei mir.

Gruß
Peter

nach oben   nach unten

Re: Dienstjahre errechnen
von: Heinz
Geschrieben am: 02.06.2002 - 19:59:46

Hallo Andreas,

deine Klammersetzung ist falsch.

Die Formel muss lauten:

=WENN(JAHR(F5)=JAHR(HEUTE());1;JAHR(HEUTE())-JAHR(F5))

Gruß Heinz

nach oben   nach unten

Danke
von: Andreas
Geschrieben am: 02.06.2002 - 20:03:05

Hallo Heinz,

danke für die prompte Antwort. Na da fühl ich mich doch gleich viel besser, dass ich nicht sooo daneben gelegen habe :)

Danke und LG
Andreas

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Dienstjahre errechnen"