alle ungerade oder gerade Zellen summieren



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: alle ungerade oder gerade Zellen summieren
von: Itchy
Geschrieben am: 20.06.2002 - 14:05:00

Wie kann ich mit einer Formel alle ungerade oder gerade Zellen einer Spalte addieren?
Wenn ich die Zellen einzeln addiere kann ich ja nur max 30 Argumente oder Zellen auswählen.

Gruß Itchy


nach oben   nach unten

Re: alle ungerade oder gerade Zellen summieren
von: Alan Hathway
Geschrieben am: 20.06.2002 - 14:39:41

Auf Anhieb fällt mir nur eine Lösung mit einer Hilfsspalte ein.

Deine Zahlen sind in Spalte A
Schreib in B1 die Formel
=ZEILE()-(GANZZAHL(ZEILE()/2)*2)
und kopiere diese Formel nach unten.
Jetz kann man SUMMEWENN benutzen
=SUMMEWENN(B1:B8;"=0";A1:A8)
ist die Formel für alle gerade Zeilen

nach oben   nach unten

Re: alle ungerade oder gerade Zellen summieren
von: Andreas
Geschrieben am: 20.06.2002 - 15:04:45

Hallo Itchy,

dazu bedarf es einer kleinen Array-Formel, also folgende Formel mit STRG+SHIFT+ENTER abschließen:

für gerade Zellen (Zeilen):
=SUMME(WENN(REST(ZEILE(A1:A100);2)=0;A1:A100;0))
für ungerade Zellen:
=SUMME(WENN(REST(ZEILE(A1:A100);2)=1;A1:A100;0))

Viel Spaß,
Andreas

nach oben   nach unten

Re: alle ungerade oder gerade Zellen summieren
von: Itchy
Geschrieben am: 20.06.2002 - 15:16:38

Danke für den Vorschlag,
Hat wunderbar geklappt!!!!
Gibt es noch eine andere Möglichkeit, ohne eine Hilfsspalte???

Gruß Itchy


nach oben   nach unten

Re: alle ungerade oder gerade Zellen summieren
von: Itchy
Geschrieben am: 20.06.2002 - 15:48:46

Voll geil!!!!!!!!!!
Hat auf anhieb geklappt!!!!!
Du bist der größte für mich!!!!!


Gruß Itchy


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "alle ungerade oder gerade Zellen summieren"