Matrixformel zum Zählen von Werten



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Matrixformel zum Zählen von Werten
von: André Mantz
Geschrieben am: 25.06.2002 - 09:50:11

Hallo zusammen,

ich habe eine Urlaubsliste mit Mitarbeitern verschiedener Abteilungen. Nun möchte ich in der Spalte Urlaub die Anzahl der Urlaubstage zusammenzählen, aber nur für die Mitarbeiter einer bestimmten Abteilung.

Das ganze sieht vereinfacht so aus:

A B C
1 Name Abteilung Urlaub
2 Maier Verkauf U
3 Müller Verkauf
4 Schmidt Technik U
5 Bauer Verkauf U
6 Busch Technik
7 Hoferer Technik
8 Baier Technik
9 Jansen Verkauf U
10


Um nun zu zählen wieviele Mitarbeiter aus dem Verkauf Urlaub habe wollte ich folgende Matrixformel in Feld C10 verwenden: {=zählenwenn(B1:B9&C1:C9;"Verkaufu")}

Allerdings wird diese Formel von Excel nicht akzeptiert.
Leider kann ich auch nicht mit einer Hilfsspalte arbeiten, da es sich um ca. 500 Mitarbeiter handelt, und für jeden Tag des Jahres eine Spalte "Urlaub" existiert, die einzeln gezählt werden müssen. Mit Hilfsspalten sind das dann 182500 zu berechnende Hilfsfelder ... was eine Riesendatei erzeugt und ewig langsam ist.

Ich hoffe mal, dass jemand einen Tip für mich hat (muss unter Excel 2000 UND Excel XP fuktionieren).
Danke für eure Hilfe,

André Mantz

nach oben   nach unten

Re: Matrixformel zum Zählen von Werten
von: MikeS
Geschrieben am: 25.06.2002 - 10:14:56

Hallo Andre`,

versuch`s mal so:

Tabelle: Tabelle1

 ABC
1NameAbteilungUrlaub
2MaierVerkaufU
3MüllerVerkaufU
4SchmidtTechnikU
5BauerVerkaufU
6BuschTechnik 
7HofererTechnik 
8BaierTechnik 
9JansenVerkaufU
10   
11 Anzahl:4
12   
13Formel in Zelle C11:  
14 {=SUMME(WENN(($B$2:$B$9="Verkauf")*($C$2:$C$9="U");1))}  
15geschweifte Klammer mit Strg+Shift(Umschalt)+Eingabe-Taste eingeben  

Klappt es nun???

Ciao MikeS

nach oben   nach unten

Danke!!!
von: André Mantz
Geschrieben am: 25.06.2002 - 10:48:32

Hallo Mike,

danke für die super Hilfe ... klappt wunderbar. Ich versteh´s zwar noch nicht wirklich, aber das kommt mit der Zeit :-))

Gruß, André

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Matrixformel zum Zählen von Werten"