Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn Abfrage

Betrifft: Wenn Abfrage von: webrollo
Geschrieben am: 06.08.2014 15:34:07

Hallo alle alle szusammen,

ich habe eine große Bitte an Euch!
Ich würde gern in einer Formel folgende Berechnung "in einem Schritt" durchführen
und fummle mir mit der Wenn Funktion die ganze Zeit vergeblich einen ab.
Sicherlich kann das jemand hier besser als ich.

Es geht darum, bei der Berechnung von Fahrtkosten, mit den gefahrenen Kilometern zwei verschiedene Centwerte zu multiplizieren.
Die Bedingung ist, das bis zu einer Grenze von 50€ der erste und dann für den Rest der Kilometer der zweite Centwert genommen werden soll.
Ziel soll eine Gesamtsumme sein, die dann in einer Zelle als Ergebnis steht.

Kann mir da bitte jemand helfen?

Beste Grüße webrollo

  

Betrifft: AW: Wenn Abfrage von: Christian
Geschrieben am: 06.08.2014 15:51:03

Hallo,

ein Ansatz:

 ABCDE
1451,35 500,03
2501,50  0,01
3511,51   
4851,85   

Formeln der Tabelle
ZelleFormel
B1=WENN(A1<=$D$1;A1*$E$1;$D$1*$E$1+((A1-$D$1)*$E$2))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

MfG Christian


  

Betrifft: AW: Wenn Abfrage von: fcs
Geschrieben am: 06.08.2014 16:02:13

Hallo webrollo,

etwa so

=WENN(km*cent1>50*100;50+(km-(50*100)/cent1)*cent2/100;km*cent1/100)

km, cent1 und cent2 kannst du dann durch die entsprechenden Zelladressen oder auch Werte ersetzen.
=WENN(C3*$C$2>50*100;50+(C3-(50*100)/$C$2)*$C$1/100;km*$C$1/100)
=WENN(C3*42>50*100;50+(km-(50*100)/42)*21/100;C3*21/100)

Am sinnvollsten ist es wenn du für die Zellen mit den Beträgen für Cent1 und Cent2 Namen festlegst und in der Formel diese Namen verwendest.

Gruß
Franz


  

Betrifft: AW: Wenn Abfrage von: webrollo
Geschrieben am: 06.08.2014 18:53:20

Hallo Christian, hallo fcs (Franz),

vielen lieben Dank für Eure Hilfe,
war doch noch zu kompliziert für mich,
hat auch noch ne Weile gedauert bis ich raus hatte wo ich was eintragen musste.
Aber jetzt funktioniert es wunderbar.

Beste Grüsse webrollo


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn Abfrage"