Microsoft Excel

Herbers Excel/VBA-Archiv

Formel gesucht

Betrifft: Formel gesucht von: Sibylle Weber
Geschrieben am: 27.09.2014 16:02:20

Guten Tag,

folgende Formel =SUMMENPRODUKT((B5:B19 Kleinerzeichen E4)*1) macht was sie soll.
In E4 steht der Wert 18 und die Formel zählt alle Personen, die jünger als 18 sind.
Schreibt man nun in E3 das Kleiner Zeichen und ändert die Formel in
'=SUMMENPRODUKT((B5:B19=E3&E4)*1), dann ... na, sie erraten es sich.

Ist die Summenproduktformel nicht für variable Vergleichsoperatoren geeignet?
Wie sähe eine brauchbare Lösung aus?

Besten Dank im Voraus.

Gruß
Sibylle

  

Betrifft: ZÄHLENWENN von: Erich G.
Geschrieben am: 27.09.2014 16:56:16

Hi Sibylle,
probier mal C4:

 BCDE
3 5 <
4 5 18
51   
6c   
72   
822   
919   
1020   
115   
124   
133   
1421   
1522   
1623   

Formeln der Tabelle
ZelleFormel
C3=SUMMENPRODUKT((B5:B19 < E4)*1)
C4=ZÄHLENWENN(B5:B19;E3&E4)

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: Danke! von: Sibylle Weber
Geschrieben am: 28.09.2014 11:50:45

Hallo Erich,

besten Dank für Deine Lösung, die wie gewünscht funktioniert.
Einen schönen Sonntag.
Gruß
Sibylle


 

Beiträge aus den Excel-Beispielen zum Thema "Formel gesucht"