Microsoft Excel

Herbers Excel/VBA-Archiv

Verschachtelte Funktion - sverweis?

Betrifft: Verschachtelte Funktion - sverweis? von: Mörfi
Geschrieben am: 06.10.2014 19:52:16

Hallo zusammen,

ich benötige einen Wert von einem Register, dafür müssen 2 Bedingungen stimmen.
Leider weiß ich nicht welche Funktion ich hierfür brauche. Ich dachte an Sverweis mit Verschachtelung. Anbei eine Übungsdatei unter folgenden Link:

https://www.herber.de/bbs/user/92987.xlsx

  

Betrifft: AW: Verschachtelte Funktion - sverweis? von: Matze Matthias
Geschrieben am: 06.10.2014 20:02:17

Hallo Mörfi,
in deiner Datei erkenne ich das es die Nr nur einmalig gibt,

somit in H2 =WENNFEHLER(SVERWEIS($A2;'Daten 15.09.14'!$B$5:$L$8;11;0);"Allokationsnr. Nicht vorhanden")

und nach unten kopieren
Gruß Matze


  

Betrifft: AW: Verschachtelte Funktion - sverweis? von: Mörfi
Geschrieben am: 06.10.2014 20:23:45

Vielen Dank Matze, aber es handelt es sich um eine Beispieldatei in der Originaldatei müssen beide Bedingungen stimmen, um den Wert zu übernehmen. Kennst du evtl dazu eine Funktion?

Vielen Dank im Voraus


  

Betrifft: AW: Verschachtelte Funktion - sverweis? von: Matze Matthias
Geschrieben am: 06.10.2014 20:30:38

Hallo Mörfi,
dann schau dir das mal an:
http://www.excelformeln.de/formeln.html?welcher=30

Gruß Matze


  

Betrifft: AW: Verschachtelte Funktion - sverweis? von: Mörfi
Geschrieben am: 06.10.2014 21:08:37

Vielen Dank, aber dass ist zu kompliziert für meine Datei.


  

Betrifft: Profi bitte schauen ob das ohne Versatz geht von: Matze Matthias
Geschrieben am: 06.10.2014 21:24:46

Hallo Mörfi,

hab deine Datei mal abgeändert, da ich mit dem hinteren Teil der Formel "Zeile" auch nicht klar komme, nun bin halt noch kein Excel Profi :

Die Zeilen 1-3 könnten dann ausgeblendet werden..
https://www.herber.de/bbs/user/92989.xlsx

Matze


  

Betrifft: AW: Profi bitte schauen ob das ohne Versatz geht von: Mörfi
Geschrieben am: 07.10.2014 08:24:56

Hallo Matze,

Vielen Dank für deine Mühe erstmals.
Auf dem ersten Blick schaut das gut aus. Ich habeb mal die Probe gemacht und die Namen in der Spalte "nutzende Gesellschaft" geändert und somit sollte FALSE rauskommen, weil die beiden bedingungen nicht mehr stimmen. Doch die selbe Zahl steht da immernoch.


  

Betrifft: Schau den letzten Beitrag an, von: Matze Matthias
Geschrieben am: 07.10.2014 10:11:36

Hallo Mörfi,
...da ist auch eine Datei dabei. Das sollte die Lösung sein.
Matze


  

Betrifft: Rückfrage zu der Nr von: Matze Matthias
Geschrieben am: 06.10.2014 21:28:29

Hallo Mörfi,
du schreibst das BEIDE Kriterien erfüllt sein müssen!
Also kann es vorkommen das die NR bei Kaiser UND bei Hansmann vorkommen kann?
Eigentlich nutz man immer "eindeutige" ID für solche Sachen um Verwechselungen zu vermeiden!

Gruß Matze


  

Betrifft: AW: Verschachtelte Funktion - sverweis? von: Matze Matthias
Geschrieben am: 06.10.2014 21:56:04

Hallo Mörfi,
..so sollte es nun passen.

{=WENNFEHLER(INDEX('Daten 15.09.14'!L:L;VERGLEICH(1;('Daten 15.09.14'!B:B=Auswertung!A2) *('Daten 15.09.14'!J:J=Auswertung!B2);0));"Kriterienfehler") }


https://www.herber.de/bbs/user/92990.xlsx

Achtung Matrixformel mit Strg+Shift+Enter die Formel abschließen!!
Gruß Matze


 

Beiträge aus den Excel-Beispielen zum Thema "Verschachtelte Funktion - sverweis?"