Microsoft Excel

Herbers Excel/VBA-Archiv

Absolute Zelladresse

Betrifft: Absolute Zelladresse von: Frank Höppner
Geschrieben am: 20.10.2014 16:55:05

Hallo
ich benötige Hilfe bei folgendem Problem:

In 2 Spalten zähle ich mit "zählenwenn(b$2:b2;"x")die x.
Wenn in einer Spalte 10x mehr X gekommen sind als in der anderen, ist stop.
Nun soll in der nächsten Zeile die Zählung wieder neu beginnen.
Wie setzt man nun die absulute Zelladresse wieder neu ?

Geht das überhaupt ohne Makro ?

Vielen Dank

Frank

  

Betrifft: AW: Absolute Zelladresse von: Daniel
Geschrieben am: 20.10.2014 17:17:40

Hi

wenn die Anzahl der bisherigen x nur dann angezeigt werden soll, wenn in der Zeile auch ein x steht:

=Wenn(B2="x";REST(ZÄHLENWENN(B$2:B2;"x")-1;10)+1;"")
wenn die Anzahl der bis dahin aufgelaufenen "x" in jeder Zelle stehen soll (dh auch wenn in dieser Zeile kein x in Spalte B steht):
=WENN(B2="x";WENN(C1=10;1;C1+1);C1)
die Formeln sind jeweils für C2 und können nach unten gezogen werden.
Im zweiten Fall muss die Zelle C1 leer sein oder eine 0 enthalten.

Gruß Daniel


  

Betrifft: AW: Absolute Zelladresse von: Frank Höppner
Geschrieben am: 20.10.2014 17:41:48

Hallo Daniel ,

super die erste passt genau.

Vielen Dank

Frank


  

Betrifft: AW: Absolute Zelladresse von: {Boris}
Geschrieben am: 20.10.2014 17:18:31

Hi Frank,

Dein Vorhaben klingt stark nach einer Zirkelbeziehung, da sich die beiden Spalten ja quasi gegenseitig zählen (müssen).
Kannst Du mal ein Beispiel zur Verfügung stellen oder etwas zum Hintergrund sagen?

VG, Boris


 

Beiträge aus den Excel-Beispielen zum Thema "Absolute Zelladresse"