Microsoft Excel

Herbers Excel/VBA-Archiv

Hallo neopa C; Zahlen von Zeilen

Betrifft: Hallo neopa C; Zahlen von Zeilen von: Lemmi
Geschrieben am: 17.11.2014 11:12:04

Hallo Werner (neopa C),

ich hatte von Dir eine Formelaufstellung bekommen.

Stichwort: Zählen von Zeilen; 1382038; 06.10.2014

Hier sollte die Zeilen gezählt in den die Werte überschritten und unterschritten worden sind. Die Formel passt soweit.

Die dritte Formel in B7 gibt mir jedoch nicht den richtigen Wert heraus.

Kannst Du Dir die Datei nochmals anschauhen und die Formel anpassen (In?

https://www.herber.de/bbs/user/93817.xlsx
Gruß
Lemmi

  

Betrifft: von mir? kann mich nicht erinnern ... von: neopa C (paneo)
Geschrieben am: 17.11.2014 11:32:05

Hallo Lemmi,

... diese Formel für das jetzt beschriebene aufgestellt zu haben.

Hierfür müsste die Formel in B7 wie folgt aussehen:

{=SUMME(N(HÄUFIGKEIT(WENN(((I11:I29999>I$5)+(J11:J29999""); ZEILE(A11:A29999));  ZEILE(A11:A29999))>0)) }

Gruß Werner
.. , - ...


  

Betrifft: AW: von mir? kann mich nicht erinnern ... von: Lemmi
Geschrieben am: 17.11.2014 14:18:14

Hallo Werner,

leider bringe ich die Formel nicht so ans laufen wie ich Sie benötige!...

Kannst Du die Formel nochmals anpassen.
Die Bereichsauswertung soll von Spalte I bis L ausgeführt werden.

Gruß
Lemmi


  

Betrifft: nun dann ... von: neopa C (paneo)
Geschrieben am: 17.11.2014 15:01:16

Hallo Lemmi,

... so:

 ABCIJKL
5Überschitten3[n] max. 1x  pro Gerät3000100030001000
6Unterschritten5[n] max. 1x  pro Gerät    
7Gesamt6[n] max. 1x  pro Gerät-500-200-500-200
8       
9       
10   Ist-WertIst-WertIst-WertIst-Wert
1117.11.201409:00:00   3.100,00 € -    300,00 €  3.200,00 €  
1218.11.201410:00:00  -    100,00 €    1.200,00 €
1319.11.201411:00:00     
1420.11.201412:00:00    -    300,00 €
1521.11.201413:00:00   -    600,00 €  
1622.11.201414:00:00   2.700,00 €    
1723.11.201415:00:00   3.300,00 €  -    600,00 €  
1824.11.201416:00:00  -    150,00 €   
1925.11.201417:00:00  -    300,00 €   

Formeln der Tabelle
ZelleFormel
B5{=SUMME(N(HÄUFIGKEIT(WENN(I11:L29999>I$5:L$5;ZEILE(A11:A29999)); ZEILE(A11:A29999))>0))}
B6{=SUMME(N(HÄUFIGKEIT(WENN((I11:L29999<I$7:L$7)*(I11:L29999<>""); ZEILE(A11:A29999)); ZEILE(A11:A29999))>0))}
B7{=SUMME(N(HÄUFIGKEIT(WENN((I11:L29999>I$5:L$5)+(I11:L29999<I$7:L$7)*(I11:L29999<>""); ZEILE(A11:A29999)); ZEILE(A11:A29999))>0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: AW: nun dann ... von: Lemmi
Geschrieben am: 19.11.2014 09:57:22

Halo Werner,

die Formel ist soweit gut! alles Bestens!
Vielen Dank!

GRuß
Lemmi


 

Beiträge aus den Excel-Beispielen zum Thema "Hallo neopa C; Zahlen von Zeilen"