Formel für Zellbezug

Bild

Betrifft: Formel für Zellbezug
von: PeTeR
Geschrieben am: 29.05.2015 08:31:41

Hallo Formel-Experten,
in Zelle A1 steht ein Tabellenname (z.B. Aug15).
In Zelle A2 steht eine Spaltennummer (z.B 27).
Ich suche nun eine einfache Formel für ='Aug15'!AA1:AA1000, wobei Tabellenname und Spaltennummer variabel sein müssen.
Meine Lösung bisher: =Adresse(1;A2;1;1;A1)&":"&Adresse(1000;A2)
Geht das auch einfacher?
Vielen Dank für eure Ideen
PeTeR

Bild

Betrifft: AW: Formel für Zellbezug
von: Hajo_Zi
Geschrieben am: 29.05.2015 10:44:54

Tabelle1

 AB
1Aug 1528
26 

verwendete Formeln
Zelle Formel Bereich N/A
A2=SUMME(INDEX($B:$IV;1;B1-1):INDEX($B:$IV;1000;B1-1))  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.04 einschl. 64 Bit




Bild

Betrifft: mittels INDIREKT() ...
von: der neopa C
Geschrieben am: 29.05.2015 10:49:08
Hallo PeTeR,
... so: =INDIREKT(A1&"!"&ADRESSE(3;A2)&":"&ADRESSE(1000;A2);1). Allerdings bildet diese nur die Matrix der Werte.
Gruß Werner
.. , - ...

Bild

Betrifft: ergänzender Hinweis ...
von: der neopa C
Geschrieben am: 29.05.2015 10:53:33
Hallo PeTeR,
... die aufgezeigte Formel setzt jedoch momentan noch voraus, dass in A1 "Aug15" wirklich als Textwert steht und nicht als formatierter Datumswert. Wenn letzteres der Fall sein sollte, kann man dieses mittels TEXT(A1;"MMMJJ") in einen Text wandeln.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: ergänzender Hinweis ...
von: Daniel
Geschrieben am: 29.05.2015 11:23:48
Hi
wenn die Spaltennummer als zahl vorliegt, ist es einfacher, die Z1S1-Bezugsart für die Indirekt-Funktion zu wählen:

=Indirekt("'"&A1&"'!Z1S"&A2&":Z1000S"&A2;falsch)
oder:
=Indirekt(Wechseln("'"&A1&"'Z1S#:Z1000S#";"#";A2);falsch)
Gruß Daniel

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel für Zellbezug"