dynamische Formelbezüge

Bild

Betrifft: dynamische Formelbezüge
von: Stefan
Geschrieben am: 03.09.2015 11:54:18

Hallo,
ich habe in einer Datei mit 11 Tabellenblätter (=10 identische Eingabemasken) und eine Output Tabelle. Output ist eine Auswertungsmaske. Zum Beispiel steht in 'Output'A3 =SUMME('InputTabelle1'A1:Z1)
Wie gelingt es mir, den Teil 'InputTabelle1' variabel zu gestalten.
Ich möchte umsetzen: Auswahlfelt in 'Output'A1. Dort gebe ich den Namen eines der 10 Inputblätter ein, z.B. 'InputTabelle5'ein. Die Formel in 'Output'A3 soll nun sein =SUMME('InputTabelle5'A1:Z1). Geht das?
Vielen Dank für Eure Unterstützung
Stefan

Bild

Betrifft: wieder INDIREKT
von: WF
Geschrieben am: 03.09.2015 12:16:52
Hi,
vorausgeschickt:
Deine obige Formel =SUMME('InputTabelle1'A1:Z1) kann nicht funktionieren, - da fehlt das Ausrufungszeichen.
also =SUMME(InputTabelle1!A1:Z1)
dynamisch:
=SUMME(INDIREKT(A1&"!A1:Z1"))
WF

Bild

Betrifft: AW: wieder INDIREKT
von: Stefan
Geschrieben am: 03.09.2015 13:36:45
Herrlich, Danke

 Bild

Beiträge aus den Excel-Beispielen zum Thema "dynamische Formelbezüge"