Tabelle auslesen für Werner :-)

Bild

Betrifft: Tabelle auslesen für Werner :-)
von: snewi
Geschrieben am: 25.09.2015 07:53:35

Guten Morgen Werner!
max Datensätze sind 10!
https://www.herber.de/forum/archiv/1448to1452/t1448120.htm
Gruß

Bild

Betrifft: AW: hab es gelesen ...
von: ... neopa C
Geschrieben am: 25.09.2015 08:47:36
Hallo snewi,
... werde es mir wie angekündigt am WE vornehmen.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: hab es gelesen ...
von: snewi
Geschrieben am: 25.09.2015 09:14:37
Super Danke :-)

Bild

Betrifft: und zu
von: robert
Geschrieben am: 25.09.2015 12:59:27


Bild

Betrifft: AW: wieso zu? ...
von: ... neopa C
Geschrieben am: 25.09.2015 16:44:30
Hallo Robert.
... ich hab doch snewi geschrieben, dass ich mich seiner Aufgabenstellung am WE annehme.
Gruß Werner
.. , - ...

Bild

Betrifft: Sorry, ich öffne wieder :-) owT
von: robert
Geschrieben am: 25.09.2015 16:52:35


Bild

Betrifft: AW: mit VERWEIS, INDEX, ZHLENWENN, AGGREGAT() ...
von: ... neopa C
Geschrieben am: 26.09.2015 09:20:51
Hallo snewi,
... in insgesamt nur 5 verschiedenen Formeln, allerdings auch mit 5 Hilfsspalten. Jedoch durch die Hilfsspalten ist es egal wie viele Daten in den entsprechenden Ergebniszellen verkettet werden müssen.
Als erstes musst Du jedoch in Deiner Datei noch das fehlende "s" (ausschliessen) in J3 und N3 ergänzen!
Die Hilfsspaltenformeln S2 und T2 ziehend nach unten kopieren, die Formeln der Hilfsspalte T zusätzlich nach rechts.
Die Ergebnisformeln J5 und L5 und M5 ziehend nach unten kopieren und die Formeln der Spalte J zusätzlich nach Spalte K. Danach für diese Ergebniszellen das Format aus N5:Q13 übertragen. Sollen die 0-Ergebniswerte in Spalte M nicht angezeigt werden, dann diesen Zellen das benutzerdefinierte Zahlenformat: 0;; noch zuweisen. Anschließend den Bereich J5:M13 nach N5:Q13 kopieren.

 ACEFGIJKLMNOPQRSTUVW
1IDAGGRPARAMVALSTRVAL           LOausschliessenLOerzwingenDOausschliessenDOerzwingen
21DOAusschliessen 1107 LO DO 1DOAusschliessen  1107 
31LOErzwingen 1122 ausschliessenerzwingenmaxausschliessenerzwingenmax 1LOErzwingen 1122  
41LOErzwingen 1125IDNrMengeNrMenge 1LOErzwingen 1122, 1125  
51LOAusschliessen 1107111071122, 1125 011071125, 1122 0 1LOAusschliessen1107   
61DOErzwingen 11252  11073000     1DOErzwingen   1125
71DOErzwingen 11223  11071500     1DOErzwingen   1125, 1122
82LOMax3000110741102, 1101 1107800     2LOMax    
93LOMax1500110751102, 1101 1107600     3LOMax    
104LOMax800110761101, 1102 1107500     4LOMax    
114LOAusschliessen 110271107, 1101, 1102  01101, 1102, 1107  0 4LOAusschliessen1102   
124LOAusschliessen 110181107, 11911125, 1122 01191, 11071122, 1125 0 4LOAusschliessen1102, 1101   
135LOMax60011079         5LOMax    
145LOAusschliessen 1102          5LOAusschliessen1102   
155LOAusschliessen 1101          5LOAusschliessen1102, 1101   

Formeln der Tabelle
ZelleFormel
S2=A2&C2&E2
T2=WENN($S2=$A2&T$1;WENN(ZÄHLENWENN($S$1:$S1;$S2)>0;VERWEIS(9;1/($S$1:$S1=$S2); T$1:T1)&", ";"")&$G2;"")
J5=WENNFEHLER(VERWEIS(9;1/($A$2:$A$500=$I5)/($C$2:$C$500=I$2&J$2)/($E$2:$E$500=J$3); INDEX($T$2:$W$500;;VERGLEICH(I$2&J$2&J$3;$T$1:$W$1;))); "")
L5=WENNFEHLER(INDEX($G:$G;AGGREGAT(14;6;ZEILE(A$2:A$500)/($F$2:$F500=M5)/(M5<>0)/($A$2:$A$500=$I5)/($C$2:$C$500=J$2); 1)); "")
M5=WENNFEHLER(AGGREGAT(14;6;$F$2:$F500/($A$2:$A$500=$I5)/($C$2:$C$500=J$2); 1); "")

Gruß Werner
.. , - ...

Bild

Betrifft: AW: mit VERWEIS, INDEX, ZHLENWENN, AGGREGAT() ...
von: snewi
Geschrieben am: 28.09.2015 12:04:07
Hammer!!!! Danker Werner läuft!

Bild

Betrifft: AW: noch nachgefragt ...
von: ... neopa C
Geschrieben am: 28.09.2015 12:11:17
Hallo snewi,
... hast Du Dir auch meinen Formelvorschlag im Deinem anderen thread hier: https://www.herber.de/forum/archiv/1448to1452/t1449412.htm schon angeschaut?
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Tabelle auslesen für Werner :-)"