automatischer Transport von Werten ...

Bild

Betrifft: automatischer Transport von Werten ...
von: Carla
Geschrieben am: 12.10.2015 11:51:28

Hallo Zusammen,
ich habe leider Probleme mit meiner Zahlungsplan-Datei.
Die Werte aus dem Tabellenblatt 'RechStlPlan' sollen in dem zweiten Tabellenblatt 'ZahlPlan' _
automatisch in die entsprechende Zelle geschrieben werden. Sprich ... ein Wert ist im Monat 10/ _ 15 bei einem Zahlungsziel von 60, dann soll er im Zahlplan in der Spalte 12/15 erscheinen. Dazu erhielt ich mal aus dem Forum (Anfang August v. Sepp) folgende Formel:


WENNFEHLER(WENN(SPALTE(A$1)-(($D3/30)*(ISTZAHL($D3)))<=0;"";
INDEX(RechStlPlan!$F$3:$U$51;ZEILE($A1); SPALTE(A$1)-(($D3/30)*(ISTZAHL($D3)))));"") 

Leider funktioniert diese nun mehr und ich finde den Fehler nicht.
Vllt. erkennt jemand den Fehler ... Danke und Grüße
Carla
https://www.herber.de/bbs/user/100723.xlsx

Bild

Betrifft: AW: automatischer Transport von Werten ...
von: Carla
Geschrieben am: 12.10.2015 12:31:56
kleiner Hinweis: die Tabellenblätter sind eingekürzt. Der Indexbereich beginnt bei F3 und endet bei U51 in beiden Tabellenblättern.

Bild

Betrifft: AW: nicht ganz eindeutig, aber ...
von: ... neopa C
Geschrieben am: 12.10.2015 12:38:35
Hallo Carla,
... möglicherweise meinst Du für F3:


=WENNFEHLER(WENN(SPALTE(A$1)-(($D3/30)*(ISTZAHL($D3)))<0;"";INDEX(RechStlPlan!$F$3:$U$51;ZEILE(A1); SPALTE(A$1)-(($D3/30)*(ISTZAHL($D3)))));"") 
und diese Formel nach rechts und unten ziehend kopieren. Oder?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: nicht ganz eindeutig, aber ...
von: Carla
Geschrieben am: 12.10.2015 15:46:30
Hallo Werner, mit dieser Formel klappt es wieder ... Danke!!!
Du hattest lediglich aus <=0 ... <0 und aus Zeile ($A1) ... Zeile (A1) gemacht. Für die Zukunft und um es besser verstehen zu können, würde ich gerne die Details erfahren. Was muss ich beachten?
Danke und Grüße
Carla

Bild

Betrifft: AW: nicht nur das ...
von: ... neopa C
Geschrieben am: 12.10.2015 15:54:27
Hallo Carla,
... wenn Du Deine hier eingestellte Datei nochmal selbst downlädst, dann stellst Du fest, dass in Deiner Formel von F3 u.a. ein Bezugsfehler vorlag, der durch WENNFEHLER() zwar abgefangen wurde aber so von Dir nicht gewollt war. Du hattest die Formel die die "Laufvariablen" ZEILE(A1) beinhaltet, offensichtlich in einer Zeile größer Zeilennummer 3 eingesetzt und die Formel dann nach oben kopiert, was den Bezugsfehler verursacht hat. Diesen hab ich korrigiert.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "automatischer Transport von Werten ..."