Vergleich Übereinstimmung 2 Zahlen-Datensätze

Bild

Betrifft: Vergleich Übereinstimmung 2 Zahlen-Datensätze
von: Joerschi
Geschrieben am: 07.11.2015 11:33:33

Hallo liebes Forum,
folgendes Problem soll gelöst werden, aber ich komme über Ideen und Ansatz nicht hinaus.
Gleich zu Anfang mit Skizze, darunter Erläuterung:
Userbild
https://www.herber.de/bbs/user/101305.xlsx
Gegeben sind in einer Zeile B4:K4 linksseitig jeweils bis zu 10 Ziffern (Vorgabewerte).
Falls weniger Ziffern vorkommen, befindet sich in den freien Zellen ein "X".
Rechtsseitig befindet sich in M4 bis P4 je eine Zeile mit Vergleichswerten.
In diesen wird niemals ein "X" auftauchen, sondern höchstens leere Felder.
Gesuchte Lösung 1:
In Spalte R soll nun verglichen werden, wie viele Übereinstimmungen es gibt (Ausgabe Anzahl).
"X" in den Vorgabewerten sollen ignoriert werden, Leerzeichen in den Vergleichswerten ebenfalls.
Die Übereinstimmungen sind positionsunabhängig.
Gesuchte Lösung 2:
In Spalte T4:AC4 und Folgezeilen sollten optimalerweise noch von li nach re die Doppler namentlich ausgegeben werden.
Mein Ansatz war der der Befehl "Vergleich", nur dann weiter...
Hätte jemand einen Tip?
Die richtigen Lösungen sind oben übrigens schon händisch eingetragen.
Danke im Voraus und liebe Grüße
Joerschi

Bild

Betrifft: mit INDEX und MTRANS
von: WF
Geschrieben am: 07.11.2015 12:51:01
Hi,
in T4 folgende Arrayformel:
{=WENNFEHLER(INDEX($B4:$K4;KKLEINSTE(WENN(($B4:$K4=MTRANS($M4:$P4))*SPALTE($A1:$J1)>0; ($B4:$K4=MTRANS($M4:$P4))*SPALTE($A1:$J1));SPALTE(A1)));"") }
nach rechts und nach unten kopieren
Salut WF

Bild

Betrifft: AW: mit AGGREGAT() und ZÄHLENWENN() einfacher ...
von: ... neopa C
Geschrieben am: 07.11.2015 14:28:41
Hallo Joerschi,
... in T4: =WENNFEHLER(AGGREGAT(15;6;$B4:$K4/ZÄHLENWENN($M4:$P4;$B4:$K4);SPALTE(A1));"")
und nach rechts und unten kopieren.
In R4 dann einfach: =ANZAHL(T4:AC4)
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Danke und Nachfrage
von: Joerschi
Geschrieben am: 07.11.2015 14:48:29
Besten Dank für die Lösungsvorschläge @ Neopa & WF
Frage: lässt sich die Anzahl in R auch ohne den Umweg der 2. Lösung direkt bestimmen?
In meiner späteren Datei würde es nämlich so umgesetzt, Lösung 2 ist eher ein "Bonus" (aber ist halt erstmal mehr Beschlagnahmung von Rechenressourcen bei Ca. 10.000 Zeilen...)
Liebe Grüße
joerschi

Bild

Betrifft: =SUMMENPRODUKT(ZÄHLENWENN($M4:$P4;$B4:$K4))
von: WF
Geschrieben am: 07.11.2015 15:03:00
.

Bild

Betrifft: OK - funktioniert allerdings nur mit Zahlen
von: WF
Geschrieben am: 07.11.2015 14:56:08
.

Bild

Betrifft: AW: Ok, angenommen man ersetzt
von: Joerschi
Geschrieben am: 07.11.2015 14:59:47
jedes "X" durch eine "999".
Wie müsste man es dann machen?
LG, Joerschi
PS: Bin jetzt erstmal bis abends offline

Bild

Betrifft: AW: musst Du aber doch nicht owT
von: ... neopa C
Geschrieben am: 07.11.2015 15:17:50
Gruß Werner
.. , - ...

Bild

Betrifft: AW: funktioniert auch mit Texten und in Mix ...
von: ... neopa C
Geschrieben am: 07.11.2015 15:16:52
Hallo WF,
... nur dass dann noch INDEX() und hier SPALTE() ins Speil kommen:

 BCDEFGHIJKLMNOPQRSTUVWXYZ
4bc13XXXXXXX bc   2 bc     
5ahXXXXXXXX defc 0        
6agXXXXXXXX 25a3  1 a      
7910g13XXXXXX 1311g  2 g13     
81633XXXXXXXX 58x1 8 XXXXXX 
922gXXXXXXXX g1   1 g      

Formeln der Tabelle
ZelleFormel
R4=SUMMENPRODUKT(ZÄHLENWENN($M4:$P4;$B4:$K4))
T4=WENNFEHLER(INDEX(4:4;AGGREGAT(15;6;SPALTE($B4:$K4)/(ZÄHLENWENN($M4:$P4;$B4:$K4)); SPALTE(A1))); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: das passt
von: WF
Geschrieben am: 07.11.2015 15:30:58
.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Vergleich Übereinstimmung 2 Zahlen-Datensätze"