Microsoft Excel

Herbers Excel/VBA-Archiv

Inhalte aus Tabellen lückenlos darstelle

Betrifft: Inhalte aus Tabellen lückenlos darstelle von: Fabian S.
Geschrieben am: 02.09.2020 11:30:13

Liebe Herber-Community,

untenstehend eine Excel-Datei, die sich auf die folgende Beschreibung bezieht.

Kurz zum Aufbau:
Im Tabellenblatt "Gantt-Chart" werden Projekte kategorisiert und benannt. Die Dropdown-Felder beruhen auf dem Tabellenblatt "Basis_Dropdown".

Die Herausforderung für mich ist folgende:
Ich möchte gerne im Tabellenblatt "Basis Dropdown" (Spalten C bis O), alle Projekte (gegliedert nach Unternehmensbereichen) aufführen, die im Tabellenblatt "Gantt-Chart" das Merkmal "Reportingort 2" (Spalte D) und alles außer "Abgeschlossen" in Spalte E erfüllen.

Das heißt, dass ich in diesem Beispiel gerne im Tabellenblatt "Basis_Dropdown" (Spalte G) die Zeilen 4, 7, 18 (also Projekte 2, 15 und 16) nacheinander und lückenlos aufgezählt habe.

Um die oben genannten Kriterien schon einmal abzudecken habe ich im Tabellenblatt "Gantt-Chart" eine Hilfsspalte B eingefügt, die diese Kriterien abfragt und den Wert dort nur ausgibt, wenn diese erfüllt sind

Kurz und knapp zusammengefasst:
Ich benötige eine Formel mit der ich alle Projekte (Spalte A) gegliedert nach den jeweiligen Unternehmensbereichen (Spalte B) lückenlos auflisten kann. Bestenfalls direkt in das Tabellenblatt "Basis_Dropdown".
Wichtig dabei ist selbstverständlich, dass sich die Formel nicht nur auf die vorhandenen Daten bezieht, sondern auch neu angelegte Zeilen automatisch berechnen kann.

Über Ihre/Eure Hilfe würde ich mich sehr freuen.
Gerne lassen ich Ihnen/Dir eine kleine Spende für erfolgreiche Hilfe zukommen.

Vorab vielen lieben Dank und viele Grüße
Fabian

Link zu Dropbox-Datei (Datei-Upload funktioniert hier leider nicht):
https://www.dropbox.com/scl/fi/7t0w2e52wopo8l94gjziz/Entwurf_Gantt-Reporting_TEST.xlsx?dl=0&rlkey=q84quuhzyyj97xuljtywywrpa

Betrifft: AW: arbeitest Du mit einem Mac? ...
von: neopa C
Geschrieben am: 02.09.2020 11:41:45

Hallo Fabian,

... dann kannst Du Deine Datei gezippt hier einstellen, wenn die Datei nicht größer 300 KB ist.
Ansonsten funktioniert der Dateiupload hier im Forum schon.

Gruß Werner
.. , - ...

Betrifft: AW: Inhalte aus Tabellen lückenlos darstelle
von: Fabian S.
Geschrieben am: 02.09.2020 12:28:07

https://www.ms-office-forum.net/forum/showthread.php?p=1996900&posted=1#post1996900

Hier kann die Datei heruntergeladen bzw. auch beantwortet werden.
LG Fabian

Betrifft: AW: das geht aber nur ...
von: neopa C
Geschrieben am: 02.09.2020 12:43:33

Hallo Fabian,

... wen man im dortigen Forum angemeldet ist, bin ich nicht, oder sich dort anmeldet, möchte ich nicht.

Gruß Werner
.. , - ...

Betrifft: AW: das geht aber nur ...
von: Nepumuk
Geschrieben am: 02.09.2020 14:01:33

Hallo Werner,

hier die Datei:

https://www.herber.de/bbs/user/139992.xlsx

Gruß
Nepumuk

Betrifft: AW: mit INDEX() und AGGREGAT() ...
von: neopa C
Geschrieben am: 02.09.2020 16:00:58

Hallo Fabian,

... in G3 z.B. so:
=WENNFEHLER(INDEX('Gantt-Chart'!$A:$A;AGGREGAT(15;6;ZEILE(Tabelle4[Projektbezeichnung])/(Tabelle4[Basis Reporting]=INDEX($2:$2;SPALTE()));ZEILE(G1)));"")

Formeln nach links und rechts kopierbar.

Gruß Werner
.. , - ...

Betrifft: AW: genau genommen ...
von: neopa C
Geschrieben am: 02.09.2020 16:09:28

Hallo,

... müsste der absolute Bezug 'Gantt-Chart'!$A:$A auch ersezt werden.

Dann so:

=WENNFEHLER(INDEX(Tabelle4[Projektbezeichnung];AGGREGAT(15;6; (ZEILE(Tabelle4[Projektbezeichnung])-ZEILE(Tabelle4[#Kopfzeilen])) /(Tabelle4[Basis Reporting]=INDEX($2:$2;SPALTE()));ZEILE(G1)));"")

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Inhalte aus Tabellen lückenlos darstelle"