Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema CheckBox
BildScreenshot zu CheckBox CheckBox-Seite mit Beispielarbeitsmappe aufrufen
Informationen und Beispiele zum Thema Userform
BildScreenshot zu Userform Userform-Seite mit Beispielarbeitsmappe aufrufen

Checkbox aktivieren, wenn ...

Betrifft: Checkbox aktivieren, wenn ... von: Marko
Geschrieben am: 18.09.2020 09:29:19

Hallo,
wie kann ich automatisch in der CheckBox1 der Haken setzen, wenn in der Tabelle13 - Zelle B13 eine 1 steht?
Und wenn in Tabelle13 - Zelle B13 eine 0 steht, dann soll der Haken nicht gesetzt werden.
Vielen Dank im Voraus...

Betrifft: AW: Checkbox aktivieren, wenn ...
von: Werner
Geschrieben am: 18.09.2020 09:33:37

Hallo,

CheckBox direkt auf einem Tabellenblatt oder auf einer Userform. Wenn auf einem Tabellenblatt - in welchem.

Und weitere Frage: Wie kommt die 0 oder 1 auf Tabelle13 zustande? Händische Eingabe oder als Ergebnis einer Formelberechnung?

Am besten wäre es, du würdest deine Datei hier hochladen.

Gruß Werner

Betrifft: AW: Checkbox aktivieren, wenn ...
von: Marko
Geschrieben am: 18.09.2020 09:40:31

Hallo Werner,
auf Tabellenblatt "TB" und nicht auf einer Userform.
Die 0 oder 1 wird berechnet mit der Formel =WENN(D13="Ja";1;0)

Betrifft: AW: Checkbox aktivieren, wenn ...
von: Werner
Geschrieben am: 18.09.2020 09:58:55

Hallo,

was nach wie vor unklar ist. Befindet sich die Checkbox sowie die Zelle die auf Ja geändert wird auf dem gleichen Tabellenblatt?
Wenn ja:
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Address(0, 0) = "D13" Then
    ActiveSheet.CheckBox1 = UCase(Target) = "JA"
End If
End Sub

Der Code gehört ins Codemodul des entsprechenden Tabellenblattes.
Rechtsklick auf den Tabellenblattreiter - Code anzeigen - Code rechts ins Codefenster kopieren.

Gruß Werner

Betrifft: AW: Checkbox aktivieren, wenn ...
von: Marko
Geschrieben am: 18.09.2020 10:07:04

Vielen Dank Werner...

Betrifft: Gerne u. Danke für die Rückmeldung. o.w.T.
von: Werner
Geschrieben am: 18.09.2020 10:43:51



Beiträge aus dem Excel-Forum zum Thema "Checkbox aktivieren, wenn ..."