Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn-Funktion

Betrifft: Wenn-Funktion von: Lena Fischer
Geschrieben am: 21.09.2020 13:32:13

Hi,
ich habe wieder mal eine Frage..

wie könnte eine Funktion lauten, wenn folgende Bedingungen eingehalten werden müssen:
-Wert aus Zelle B1 und C1 addrieren, wenn in Zelle A1 "Haus" steht

-Wert aus Zelle B1 und C1 subtrahieren, wenn in Zelle A1 "Maus" steht.

Das problem ist, dass in Zelle A1 nicht nur "Haus" und "Maus" steht sondern DAVOR auch zahlen und andere Buchstaben, also wie z.B. "F12Haus" oder "XXL1Haus" (also das sind jetzt nur 2 möglichkeiten war vor "Haus" und "Maus" stehen könnte, es gibt noch viele viele andere möglichkeiten.

Liebe Grüße

Betrifft: AW: Eine Beispielmappe wäre weniger verwirrend...
von: EtoPHG
Geschrieben am: 21.09.2020 13:38:16

Hallo Lena,

Aber Haus & Maus sind die Teile, welche die unterschiedlichen Operatione (+/-) auslösen sollen?
Oder sind es doch etwa die F12..XXL1 vor dem Ausdruck Haus?

Bitte formuliere deine Frage genauer, oder stelle eine Beispielmappe ins Forum!

Gruess Hansueli

Betrifft: AW: (m)eine Interpreation dessen ...
von: neopa C
Geschrieben am: 21.09.2020 13:50:19

Hallo Lena,

... wäre: =WAHL(1+ISTZAHL(FINDEN("Haus";A1))+ISTZAHL(FINDEN("Maus";A1))*2;"";B1+C1;B1-C1)
wobei nicht eindeutig ist, ob Du bei Deiner Subtraktion anstelle B1-C1 evtl. C1-B1 meinst.

Gruß Werner
.. , - ...

Betrifft: AW: (m)eine Interpreation dessen ...
von: Lena Fischer
Geschrieben am: 21.09.2020 13:53:01

vielen Dank für die Hilfe

Betrifft: AW: (m)eine Interpreation dessen ...
von: Lena Fischer
Geschrieben am: 21.09.2020 13:53:03

vielen Dank für die Hilfe

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 21.09.2020 14:10:41

Gruß Werner
.. , - ...

Betrifft: AW: Wenn-Funktion
von: onur
Geschrieben am: 21.09.2020 14:11:17

Noch eine Variante:
=WENNFEHLER(WENN(FINDEN("Haus";$A1)>0;$B1+$C1;"");WENNFEHLER(WENN(FINDEN("Maus";$A1)>0;$B1-$C1;""); "")) 


Beiträge aus dem Excel-Forum zum Thema "Wenn-Funktion"