Microsoft Excel

Herbers Excel/VBA-Archiv

Anwesende Personen im Zeitraum anzeigen

Betrifft: Anwesende Personen im Zeitraum anzeigen von: Sebastian
Geschrieben am: 22.09.2020 16:40:08

Hallo Profis,

ich möchte gerne die anwesenden Personen in einem bestimmten Zeitraum berechnen lassen.
die Beispieldatei habe ich mal hochgeladen.
https://www.herber.de/bbs/user/140370.xlsx

Im Prinzip möchte ich z.B. anzeigen lassen wie viele Personen von 8-10 Uhr da sind. Die Zeiten von bis je Person stehen in B und C.

Vielleicht hat jemand einen Tip wie ich das machen kann.

Vielen Dank und viele Grüße
Sebastian

Betrifft: AW: Anwesende Personen im Zeitraum anzeigen
von: UweD
Geschrieben am: 22.09.2020 16:50:01

HAllo
Formel in D6: =ZÄHLENWENNS($B$18:$B$22;"<="&B6;$C$18:$C$22;">="&C6)
Dann nach unten kopieren


LG UweD

Betrifft: AW: Anwesende Personen im Zeitraum anzeigen
von: Sebastian
Geschrieben am: 22.09.2020 16:56:12

Danke für die Antwort - aber das geht leider nicht. In Spalte D8 sollten eigentlich "4" Personen möglich sein :-(

Betrifft: AW: Anwesende Personen im Zeitraum anzeigen
von: UweD
Geschrieben am: 22.09.2020 17:00:25

Meine Formel sagt aus, ob Mitarbeiter mindestens in dem Bereich da waren.





Wenn Sie um.. oder später gekommen sind und spätestens um.. gegangen sind, dann > < Zeichen drehen
=ZÄHLENWENNS($B$18:$B$22;">="&B6;$C$18:$C$22;"<="&C6)


Betrifft: AW: Anwesende Personen im Zeitraum anzeigen
von: Daniel
Geschrieben am: 22.09.2020 16:52:47

Hi
mit ZählenWenns.
wie genau hängt davon ab, wie du Personen Zählen willst, die zwischen 8 und 10 kommen oder gehen, also nicht den vollen Zeitraum da sind.

=zählenWenns(B:B;"<=8:00";C:C;">=10:00")
=zählenWenns(B:B;"<10:00";C:C;">8:00")

Gruß Daniel

Betrifft: AW: Anwesende Personen im Zeitraum anzeigen
von: Sebastian
Geschrieben am: 22.09.2020 17:02:12

Hi Daniel,

auch deine Version geht nicht.

Vielleicht habe ich das auch falsch beschrieben.

Ich möchte wissen wie viele Personen im Zeitraum von 7:00 Uhr bis 15 UHr da sind.

Es sollte egal sein ob die Person 8 Uhr bis 13 Uhr da ist oder 7- 12 Uhr. Beide sind im Zeitraum 7 - 15 Uhr anwesend und sollten zählen.


Betrifft: AW: Anwesende Personen im Zeitraum anzeigen
von: Sebastian
Geschrieben am: 22.09.2020 17:11:40

Daniel seine Lösung geht, bissel Modifiziert mit Uwe seiner Lösung. Danke euch beiden

=ZÄHLENWENNS($B$18:$B$22;"<="&B6;$C$18:$C$22;">="&C6)

Danke Euch

Betrifft: AW: wie das? ...
von: neopa C
Geschrieben am: 22.09.2020 17:24:07

Hallo Sebastian,

... mit Deiner hier aufgezeigten Formel kommst Du in D8 aber nicht auf 4 sondern auf 0.

So wie Du es zuvor verbal beschrieben hast, würde ich in D6 folgende Formel vorschlagen:

=ZÄHLENWENNS($B$18:$B$22;"<="&C6;$C$18:$C$22;">="&B6)

deren Ergebnisse aber gänzlich nicht mit Deinen Vorgabewerten übereinstimmen.

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Anwesende Personen im Zeitraum anzeigen "