Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis+Vergleich

Betrifft: Sverweis+Vergleich von: abcde
Geschrieben am: 23.09.2020 22:34:27

Hallo,


ich habe hier folgende Beispieldatei:


https://www.herber.de/bbs/user/140391.xlsx



Ziel ist es, den richtigen Prozentwert abhängig von Währung, Risikogruppe und Tag in die grün unterlegte Zelle zu bekommen. Die aktuelle Formel dort greift leider auf den falschen Wert zu (500% wäre richtig). Wo liegt der Fehler?


Danke im Voraus!

Betrifft: Koordinaten per Doppel-Vergleich
von: WF
Geschrieben am: 23.09.2020 22:57:08

Hi,

in B12:
=INDEX(D$2:F$9;VERGLEICH(A12;C$2:C$9;0);VERGLEICH(I2;D$1:F$1;0))
runterkopieren

WF

Betrifft: AW: Koordinaten per Doppel-Vergleich
von: GerdL
Geschrieben am: 23.09.2020 23:10:02

Moin.
ab Spalte B nach rechts ziehen.
=TEIL(TEXT($A3;"000,000");SPALTE(A1);1)
Gruß Gerd

Betrifft: AW: Falschen Beitrag erwischt!
von: GerdL
Geschrieben am: 23.09.2020 23:12:03

Entschuldigung
Gerd

Betrifft: AW: Koordinaten per Doppel-Vergleich
von: abcde
Geschrieben am: 24.09.2020 10:48:54

@WF

Funktioniert leider nicht, da "I2" in der zweiten Vergleichs -Formel dynamisch ist und damit nicht für EUR die Prozentwerte für jeden Tag wiedergibt( also alle Werte in Spalte E unter "2"), sondern in B12 dann der Wert für USD steht

Betrifft: AW:SVERWEIS() und VERGLEICH() reicht schon ...
von: neopa C
Geschrieben am: 24.09.2020 07:38:07

Hallo,

... nur hast Du Deinem VERGLEICH() die falsche Startspalte in der Suchmatrix übergeben und zwar D anstelle richtig C.

Die Formel lässt sich dann allerdings auch noch einkürzen, so:

=SVERWEIS(A12;C:F;VERGLEICH(SVERWEIS(A$11;H:I;2;0);C$1:F$1);0)

und nach unten kopieren.

Gruß Werner
.. , - ...