Microsoft Excel

Herbers Excel/VBA-Archiv

Hochzählen

Betrifft: Hochzählen von: Gunni
Geschrieben am: 24.09.2020 08:25:55

Hallo EXCEL-Forum,


ich habe eine für mich nicht lösbare Aufgabe und hoffe auf eure Hilfe.

Ich möchte eine Zahl in einer Spalte Zählen und jedes Mal wenn sie vorkommt soll die davor stehen wie oft sie vorkommt und beim ersten Mall soll in einer anderen Spalte ein "E" stehen und beim letzten Mal ein "A"

Nicht so einfach zu erklären, deshalb eine Beispieldatei im Anhang.

https://www.herber.de/bbs/user/140399.xlsx



Gruß

Gunni

Betrifft: AW: mit ZÄHLENWENN() ...
von: neopa C
Geschrieben am: 24.09.2020 08:43:49

Hallo Gunni,

... nachfolgende Formeln nach unten ziehend kopieren:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCD
11EA717
21EA1194
31  798
41  778
51  741

ZelleFormel
A1=ZÄHLENWENN(D$1:D1;D1)
B1=WENN(ZÄHLENWENN(D:D;D1)=1;"E";"")
C1=WENN(ZÄHLENWENN(D2:D9999;D1)=0;"A";"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Gruß Werner
.. , - ...

Betrifft: AW: mit ZÄHLENWENN() ...
von: Gunni
Geschrieben am: 24.09.2020 09:13:11

Hallo Werner,
vielen Dank für die schnelle Hilfe, es gibt ein Problem mit der Spalte "B"
Spalte "A" und "C" funktionieren perfekt, nur in Spalte "B" steht nicht das richtige.

Gruß
Gunni

Betrifft: AW: mit ZÄHLENWENN() ...
von: hary
Geschrieben am: 24.09.2020 09:26:10

Moin
Versuch es mal so in B1 und runterziehen.
=WENN(A1=1;"E";"")
gruss hary

Betrifft: AW: mit ZÄHLENWENN() ...
von: Gunni
Geschrieben am: 24.09.2020 10:11:19

Hallo hary,
vielen Dank, jetzt funktioniert alles.
Ihr seid einfach klasse.

Gruß
Gunni

Beiträge aus dem Excel-Forum zum Thema "Hochzählen"