Microsoft Excel

Herbers Excel/VBA-Archiv

Beispieldatei / Excel-Formel unbekannt

Betrifft: Beispieldatei / Excel-Formel unbekannt von: Janno
Geschrieben am: 01.10.2020 11:19:09

Hallo zusammen,


folgender Sachverhalt zu der Beispieldatei: https://www.herber.de/bbs/user/140565.xlsx



In den Zeilen sieht man verschiedene Produkte, die Kunden gekauft haben. In jeder Zeile ist ein Kauf für 1 Produkt abgebildet.

In Spalte A sieht man wenn 1 KD mehrere Produkte gekauft hat. Dies ist sichtbar anhand der identischen Kundennr.


Ziel soll sein in Spalte D für alle Produkte eines Kunden den gleichen Vertriebsmitarbeiter einzutragen. Weil wir nicht wollen, dass 1 Kunde durch mehrere Vertriebsmitarbeiter betreut wird. Wenn es anhand von Spalte C bisher so war, dass 1 Kunde von mehreren Vertriebsmitarbeitern betreut wurde, wollen wir dass in Spalte D nur noch 1 neuer betreuender Vertriebsmitarbeiter bestimmt wird. Das Kriterium, welcher Vertriebsmitarbeiter dies sein wird, soll auf Basis von Spalte B getroffen werden. Der Vertriebsmitarbeiter der zuletzt ein Produkt verkauft hat (also aktuellstes Verkaufsdatum), soll neuer betreuender Vertriebsmitarbeiter werden.


Vielleicht können Sie mir dabei helfen, wie die Formel in Spalte D hierfür aussehen müsste.


Danke & Grüße

Janno

Betrifft: AW: Beispieldatei / Excel-Formel unbekannt
von: Herbert_Grom
Geschrieben am: 01.10.2020 11:50:39

Hallo Janno,

dazu brauchst du natürlich eine Liste, welcher ADM welche Kd-Nr. betreut.

Servus

P.S.: Wer ist "Florian"?

Betrifft: AW: Beispieldatei / Excel-Formel unbekannt
von: Matthias L
Geschrieben am: 01.10.2020 12:07:56

Hi, da gibt es verschieden Varianten.

Ich würde einfach nach Datum aufsteigend sortieren
und dann nach Kundennummer filtern.
Das lässt sich auch leicht mit Pivot lösen. PQ könnte auch eine Möglichkeit sein.



Hier ist eindeutig sichtbar, welcher Betreuer als letztes betreut hat.
am 19.08.2013 Betreuer C

Tabelle1

 ABC
1Kundennr.DatumAktueller Vertriebsmitarbeiter
12111433927.10.2011D
14111433914.12.2011C
19111433928.06.2013
21111433919.08.2013C
24111433917.03.2014
31111433930.05.2016


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Sverweis wäre auch eine Option in Verbindung mit MaxWenns (Versionsabhängig!)

Gruß Matthias

Betrifft: AW: die Datenliste enthält in C Leerzeichen ...
von: neopa C
Geschrieben am: 01.10.2020 12:36:45

Hallo Janno, Florian,

... zunächst aber festgestellt, in Foren wie auch diesen schreibt man in der DU-Form.

Die von Dir angestrebte Auswertung wurde erschwert, weil sie in Spalte C in den "leeren" Zellen Leerzeichen beinhaltet.

Nachfolgend gehe ich davon aus, dass Du zumindest XL2010 im Einsatz hast und die Daten unsortiert sein können. Dafür folgende Formel in D2

=WENNFEHLER(INDEX(C:C;AGGREGAT(15;6;ZEILE(B$2:B$99)/(AGGREGAT(14;6;B$2:B$99/(A$2:A$99=A2)/(LÄNGE(GLÄTTEN(C$2:C$99))>0);1)=B$2:B$99)/(A$2:A$99=A2);1));"neu")

und nach unten kopieren.

Gruß Werner
.. , - ...