Microsoft Excel

Herbers Excel/VBA-Archiv

Stunden automatisch übernehmen

Betrifft: Stunden automatisch übernehmen von: André
Geschrieben am: 01.10.2020 18:39:25

Hallo Leute,


ich möchte gern meine Tabelle für meine Mitarbeiter verfeinern.

Im Reiter eins geben die Mitarbeiter Ihre Zeiten an denen Sie gearbeitet haben ein. Diese müssen nicht fortlaufend sein. Diese werden dann in Spalte H automatisch zusammengerechnet.


Im Reiter 4 müssen dann die Mitarbeiter momentan noch per Hand die Zeiten übertragen, bzw die Arbeitsstunden zusammenfassen. Dies sollte doch mit einer Formel möglich sein, die dies automatisch macht.


Also quasi vom Reiter 1 die Startzeit aus Spalte E + die Arbeitszeit an dem Tag aus Spalte H.

Die Anzahl der Zeilen aus Reiter 1 variieren natürlich von Tag zu Tag.

Die Zeilen aus Reiter 4 bleiben jeden Monat so, nur das sich das Datum natürlich jeden Monat ändert.


Ich hoffe Ihr könnt mir helfen.


Ich danke euch schonmal riesig für die Unterstützung


https://www.herber.de/bbs/user/140572.jpg


https://www.herber.de/bbs/user/140573.jpg

Betrifft: AW: Bitte statt jpg's Mustermappe hochladen owT
von: JoWE
Geschrieben am: 01.10.2020 18:48:09



Betrifft: AW: Bitte statt jpg's Mustermappe hochladen owT
von: André
Geschrieben am: 02.10.2020 06:44:12

https://www.herber.de/bbs/user/140581.xlsx

Betrifft: AW: Bitte statt jpg's Mustermappe hochladen owT
von: André
Geschrieben am: 02.10.2020 06:46:31

https://www.herber.de/bbs/user/140581.xlsx

Betrifft: Formelauswertung
von: MCO
Geschrieben am: 02.10.2020 09:31:55

Hallo Andre!

Wenn du dich entschließen könntest, das Datum in jede der Zeilen in Tab1 einzufügen, könntest _ du die Auwertung der Zeiten mit
=SUMMENPRODUKT(--(A3:A11=A3);G3:G11)
ermitteln.

(Berreiche anpassen, Zeilen absolut setzen fehlt....)

Anders sehe ich da keine Formellösung sondern würde eine Funktion in VBA schreiben.

Gruß, MCO

Betrifft: AW: Formelauswertung
von: André
Geschrieben am: 02.10.2020 15:23:08

Hallo, das geht leider nicht, da ich die erste Spalte mit dem Datum für eine andere Auswertung brauche.
Dort ist es wichtig das kein Datum doppelt erscheint.


Liebe Grüße