Microsoft Excel

Herbers Excel/VBA-Archiv

Stückzahl Ermittlung

Betrifft: Stückzahl Ermittlung von: Chris
Geschrieben am: 06.11.2020 12:20:20

Hallo Zusammen,


ich bräuchte von euch hilfe bei einer Formel.


Tabelle1

A B C D E F G

2 |Produkt |Farbe 1 |Stück |Farbe 2 |Stück |Farbe 3 |Stück

3 |Produkt A |F1 |2 |F3 |5 |F6 |2

4 |Produkt B |F7 |3 |F5 |6 |F4 |4

5 |Produkt C |F2 |6 |F4 |7 |F3 |9

6 |Produkt D |F6 |8 |F3 |9 |F5 |8

7 |usw.


Tabelle2

A B C

1 |Produkt |Farbe |Stück

2 |Produkt B |F4 |(Formel)


Ich möchte jetzt per Formel in der Zelle die Stückzahl eines Produktes in einer bestimmten Farbe ermitteln.

Ich habe zunächst diese Formel verwendet:


=BEREICH.VERSCHIEBEN(Tabelle1!A4;0;VERGLEICH(B2;Tabelle1!4:4;0)-2) Ergebniss: 4


Für die Fett und Kursiv markierten Stellen, um diese zu ermitteln, benutze ich dies Formeln:


Fett:

=ADRESSE(VERGLEICH(A2;Tabelle1!A:A;0);3) Ergebniss: $A$4


Kursiv:

=VERGLEICH(A2;Tabell1!C:C;0) Ergebniss: 4


Jetzt möchte ich die drei Formeln in eine Packen. Ist dies möglich?


Ich habe zwischenzeitlich für die Fett dargestellte Formal eine Lösung gefunden.

Ich habe zunächt davor der Text "Tabelle1!" eingegeben:


="Tabelle1!"&ADRESSE(VERGLEICH(A2;Tabelle1!A:A;0);3) Ergebniss: Tabelle1!$A$4


Und dieser dann eine INDIREKT Funktion gegeben:


=INDIREKT("Tabelle1!"&ADRESSE(VERGLEICH(A2;Tabelle1!A:A;0);3))


mit diese Formel habe ich dann Tabelle1!A4 in der Hauptformel ersetzt:


=BEREICH.VERSCHIEBEN(INDIREKT("Tabelle1!"&ADRESSE(VERGLEICH(A2;Tabelle1!A:A;0);3));0;VERGLEICH(B2; Tabelle1!4:4;0)-2) Ergebniss: 4


Mit Erfolg!


Mit der Kursiv markierten Formel hat es nicht funktioniert und weis nicht mehr weiter.

Gibt es denn eine Lösung?


Gruß

Chris

Betrifft: AW: Stückzahl Ermittlung
von: SF
Geschrieben am: 06.11.2020 12:21:19

Hola,

lad doch bitte eine Exceldatei hoch.

Gruß,
steve1da

Betrifft: AW: Stückzahl Ermittlung
von: Oberschlumpf
Geschrieben am: 06.11.2020 12:36:40

Moin Chris,

wieso nur schreibst du all das, was schon in der Datei (Tabelle) steht, Zeichen für Zeichen hier noch mal auf?
Wieso zeigst du nicht gleich eine Bsp-Datei per Upload?

Ciao
Thorsten

Betrifft: AW: Stückzahl Ermittlung
von: Chris
Geschrieben am: 06.11.2020 14:11:17

Hallo,



wie lade ich hier eine Tabelle hoch?



Gruß

Betrifft: AW: Stückzahl Ermittlung
von: Oberschlumpf
Geschrieben am: 06.11.2020 14:52:13

Hi,

oben rechts auf den Button klicken und den Anweisungen folgen.

Ciao
Thorsten

Betrifft: AW: Stückzahl Ermittlung
von: Chris
Geschrieben am: 07.11.2020 07:20:52

Guten Morgen,

ich habe die Excel hier hochgeladen:
https://www.herber.de/bbs/user/141380.xlsx

Gruß
Chris

Betrifft: AW: z.B. mt SUMMENPRODUKT() ...
von: neopa C
Geschrieben am: 07.11.2020 09:10:55

Hallo Chris,

.. . in C2: =SUMMENPRODUKT((Tabelle1!A$3:A$99=A2)*(Tabelle1!B$3:F$99=B2);Tabelle1!C$3:G$99)

Gruß Werner
.. , - ...

Betrifft: AW: z.B. mt SUMMENPRODUKT() ...
von: Chris
Geschrieben am: 09.11.2020 11:43:11

Funktioniert wunderbar. Vielen Dank

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 09.11.2020 16:22:27

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Stückzahl Ermittlung"