Microsoft Excel

Herbers Excel/VBA-Archiv

WENN UND Verschachtelung oder was?

Betrifft: WENN UND Verschachtelung oder was? von: Reinhard M.
Geschrieben am: 06.11.2020 11:47:25

Hallo Excel-Gemeinde,

ich hab momentan ein Brett vorm Kopf :-)

Ich hab eine Zelle, in der ein Datumswert eingetragen ist. Wenn in einer anderen Zelle ein Wert zwischen zwei Werten liegt, muss der Datumswert um z.B. einen Monat weiter zählen. Bei einem anderen Wert nur um eine Woche und bei einem Weiteren um ein viertel Jahr.

https://www.herber.de/bbs/user/141368.xlsx

Über nen Lösungsansatz wäre ich sehr dankbar.
Grüße
Reinhard

Betrifft: AW: WENN UND Verschachtelung oder was?
von: SF
Geschrieben am: 06.11.2020 11:53:50

Hola,

=WENN(UND(A10>=17;A10<=20);B10+7;WENN(UND(A10>=10;A10<=16);EDATUM(B10;1);WENN(UND(A10> =0;A10<=9);EDATUM(B10;3);"")))

Gruß,
steve1da

Betrifft: AW: WENN UND Verschachtelung oder was?
von: Reinhard M.
Geschrieben am: 06.11.2020 11:58:19

Top, danke für die schnelle Lösung *Daumen hoch*