Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

Monate berechnen mit Nachkommastellen

Betrifft: Monate berechnen mit Nachkommastellen von: Tommi
Geschrieben am: 06.11.2020 11:24:01

Liebes Forum,

ich möchte gern anhand von Datumsangaben ermitteln, wie viele Monate diese umassen. Über die Formel DATEDIF erhalte ich leider nur Monate oder Tage. Ich benötige jedoch eine Monatsangabe, die die zum nächsten vollen Monat fehlenden Tage als Nachkommestelle ausgibt.

Beispiel: A1 = 10.07.2002 | B1 = 17.11.2003 | Ergebnis in C1 = 16,3 Monate

Habt Ihr vielleicht eine Formel, die ich in C1 eingeben kann, um zum gewünschten Ergebnis zu kommen?

Herzlichen Dank und beste Grüße

Tommi

Betrifft: =(A2-A1)/30,4
von: WF
Geschrieben am: 06.11.2020 11:46:34

ist natürlich nur ne Näherungslösung.

Betrifft: AW: Monate berechnen mit Nachkommastellen
von: jk
Geschrieben am: 06.11.2020 11:54:18

Hallo,

ich würde auch sagen Du teilst die Differenz durch den Durchschnitt der Tage je Monat. (30,436875)

Also:

=(A2-A1)/30,436875

Das Ergebnis lautet dann 16,26316762
Ist das genau genug?

Betrifft: AW: Monate berechnen mit Nachkommastellen
von: Günther
Geschrieben am: 06.11.2020 12:21:30

Moin,
ich war zu Beginn auch den Web der beiden bisher geposteten Lösungen gegangen, weil imho am _ sinnvollsten. Aber um möglichst genau auf deinen Wert zu kommen eine richtig "blöde" Formel:
=DATEDIF(A1;A2;"M")+30,4/(30,4-(A2-EDATUM(A1;DATEDIF(A1;A2;"M"))))-1

Alternativ natürlich auch mit 30 statt 30,4 Tagen oder auch dem Ultimo des Monats aus A2.
 
Gruß
Günther  |  mein Excel-Blog

Betrifft: AW: Monate berechnen mit Nachkommastellen
von: Tommi
Geschrieben am: 06.11.2020 12:54:45

Liebes Forum,

ganz herzlichen Dank für Eure schnelle Unterstützung! Ich experimentiere nun mit Euren Formeln. Erste Versuche sehen im Vergleich zu den Referenzwerten (manuell an anderer Stelle berechnet) sehr vielversprechend aus.

Beste Grüße & habt ein schönes Wochnenende
Tommi

Betrifft: es gibt den Parameter "MD"
von: WF
Geschrieben am: 06.11.2020 17:34:27

Hi,

damit dann:
=DATEDIF(A1;A2;"M")+DATEDIF(A1;A2;"MD")/30,4

Killerbeispiele für die bisherigen Vorschläge:
01.02.2002 bis 02.03.2002
und
07.02.2002 bis 02.03.2002

WF

Betrifft: AW: Monate berechnen mit Nachkommastellen
von: Besserwisser
Geschrieben am: 06.11.2020 21:55:52

Hallo,



versuche mal folgende Formel:



=RUNDEN(BRTEILJAHRE(A1;B1;1)*12;1)



Viele Grüße





Christian

Betrifft: AW: Monate berechnen mit Nachkommastellen
von: Sulprobil
Geschrieben am: 08.11.2020 15:59:06

Ich finde, am genauesten wäre:
https://berndplumhoff.gitbook.io/sulprobil/excel/excel-worksheet-function-solutions/monthly-fractions
:-)

Beiträge aus dem Excel-Forum zum Thema "Monate berechnen mit Nachkommastellen"