Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Anzahl Monate im akt. Jahr

Anzahl Monate im akt. Jahr
Michael
Hallo zusammen,
folgendes Problem:
A1
16.08.2010
B1
20.02.2011
Als Ergebniss möchte ich z.B. C1=2,0 stehen haben. Ich möchte gerne die Anzahl der Monate im Jahr 2011 haben. cch hab es schon mit der Formel =(DATEDIF(A1;B1;"d"))/30 versucht. Die Fromel funktioniert aber nur bei Werten im selben Jahr.
Kann mir jemand helfen?
Danke und Gruß
Michael

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
=MONAT(HEUTE())
15.03.2011 11:39:45
Christian
Gruß
Christian
AW: =MONAT(HEUTE())
15.03.2011 11:48:13
Michael
Hallo Christian,
Aber ich möchte ja die Differenz haben. Wenn z.B.
05.05.2011 - 08.09.2011
Soll - Ergebnis = 4 Monate (und nicht 9)
Gruß
Michael
AW: =MONAT(HEUTE())
15.03.2011 12:02:55
Hajo_Zi
Hallo Michael,
Tabelle2
 ABC
916.02.200915.03.20113
1016.02.200915.03.201212
1116.02.200915.03.2010 

verwendete Formeln
Zelle Formel Bereich
C9 =WENN(UND(JAHR(A9)=JAHR(HEUTE());JAHR(B9)=JAHR(HEUTE()));MONAT(B9)-MONAT(A9);WENN(JAHR(B9)=JAHR(HEUTE());MONAT(B9);"")) 
C10 =WENN(UND(JAHR(A10)=JAHR(HEUTE());JAHR(B10)=JAHR(HEUTE()));MONAT(B10)-MONAT(A10);WENN(JAHR(B10)=JAHR(HEUTE());MONAT(B10);WENN(JAHR(B10)>JAHR(HEUTE());12;""))) 
C11 =WENN(UND(JAHR(A11)=JAHR(HEUTE());JAHR(B11)=JAHR(HEUTE()));MONAT(B11)-MONAT(A11);WENN(JAHR(B11)=JAHR(HEUTE());MONAT(B11);WENN(JAHR(B11)>JAHR(HEUTE());12;""))) 

Tabellendarstellung in Foren Version 5.40



Anzeige
AW: =MONAT(HEUTE())
15.03.2011 12:15:59
Hajo_Zi
Hallo Michael,
ich glaube ich hatte noch nicht alle Fälle abgefast.
Tabelle2
 ABC
916.02.200915.03.20113
1016.02.200915.03.201212
1116.02.200915.03.2010 
1216.02.201115.03.201211
1316.02.201115.03.20112

verwendete Formeln
Zelle Formel Bereich
C9 =WENN(UND(JAHR(A9)=JAHR(HEUTE());JAHR(B9)=JAHR(HEUTE()));MONAT(B9)-MONAT(A9)+1;WENN(JAHR(B9)=JAHR(HEUTE());MONAT(B9);WENN(UND(JAHR(A9)<JAHR(HEUTE());JAHR(B9)>JAHR(HEUTE()));12;WENN(UND(JAHR(B9)>JAHR(HEUTE());JAHR(A9)=JAHR(HEUTE()));13-MONAT(A9);"")))) 
C10 =WENN(UND(JAHR(A10)=JAHR(HEUTE());JAHR(B10)=JAHR(HEUTE()));MONAT(B10)-MONAT(A10)+1;WENN(JAHR(B10)=JAHR(HEUTE());MONAT(B10);WENN(UND(JAHR(A10)<JAHR(HEUTE());JAHR(B10)>JAHR(HEUTE()));12;WENN(UND(JAHR(B10)>JAHR(HEUTE());JAHR(A10)=JAHR(HEUTE()));13-MONAT(A10);"")))) 
C11 =WENN(UND(JAHR(A11)=JAHR(HEUTE());JAHR(B11)=JAHR(HEUTE()));MONAT(B11)-MONAT(A11)+1;WENN(JAHR(B11)=JAHR(HEUTE());MONAT(B11);WENN(UND(JAHR(A11)<JAHR(HEUTE());JAHR(B11)>JAHR(HEUTE()));12;WENN(UND(JAHR(B11)>JAHR(HEUTE());JAHR(A11)=JAHR(HEUTE()));13-MONAT(A11);"")))) 
C12 =WENN(UND(JAHR(A12)=JAHR(HEUTE());JAHR(B12)=JAHR(HEUTE()));MONAT(B12)-MONAT(A12)+1;WENN(JAHR(B12)=JAHR(HEUTE());MONAT(B12);WENN(UND(JAHR(A12)<JAHR(HEUTE());JAHR(B12)>JAHR(HEUTE()));12;WENN(UND(JAHR(B12)>JAHR(HEUTE());JAHR(A12)=JAHR(HEUTE()));13-MONAT(A12);"")))) 
C13 =WENN(UND(JAHR(A13)=JAHR(HEUTE());JAHR(B13)=JAHR(HEUTE()));MONAT(B13)-MONAT(A13)+1;WENN(JAHR(B13)=JAHR(HEUTE());MONAT(B13);WENN(UND(JAHR(A13)<JAHR(HEUTE());JAHR(B13)>JAHR(HEUTE()));12;WENN(UND(JAHR(B13)>JAHR(HEUTE());JAHR(A13)=JAHR(HEUTE()));13-MONAT(A13);"")))) 

Tabellendarstellung in Foren Version 5.40


sieht vielleicht kompliziert aus, aber es rechnet.
Gruß Hajo
Anzeige
AW: =MONAT(HEUTE())
15.03.2011 12:03:20
Christian
ja, ich weiß... hätte aber gedacht dass man mit "Excel gut" da nicht drüber reden muss...
prüfe:
Wenn das Jahr gleich ist, dann ziehe die Monate voneinander ab, sonst nimmst du den Monat von B1.
Gruß
Christian
AW: =MONAT(HEUTE())
15.03.2011 12:53:58
Erich
Hi Michael,
ich verstehe das so wie hier in Spalte C. (In D steht Hajos Formel.)
Was mir noch nicht klar ist: Wie sollen angefangene Monate gezählt werden? Stimmen die Beispielwerte?
 ABCD
916.02.200915.03.201133
1016.02.201001.03.2012312
1101.02.201101.02.201101
1231.01.201101.02.201112
1301.02.201131.03.201112

Formeln der Tabelle
ZelleFormel
C9=MONAT(B9) - (JAHR(A9)=JAHR(B9))*MONAT(A9)
D9=WENN(UND(JAHR(A9)=JAHR(HEUTE()); JAHR(B9)=JAHR(HEUTE())); MONAT(B9)-MONAT(A9)+1;WENN(JAHR(B9)=JAHR(HEUTE()); MONAT(B9); WENN(UND(JAHR(A9)<JAHR(HEUTE()); JAHR(B9)>JAHR(HEUTE())); 12;WENN(UND(JAHR(B9)>JAHR(HEUTE()); JAHR(A9)=JAHR(HEUTE())); 13-MONAT(A9); ""))))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
AW: =MONAT(HEUTE())
15.03.2011 13:04:05
Michael
Hallo zusammen,
super Vielen Dank. Formel für Spalte D (Hajos Formel) ist korrekt.
Gruß
Michael
Alternative
15.03.2011 13:15:03
Erich
Hi,
dann hätte ich noch eine andere SPalte C im Angebot:
 ABCDE
216.02.200915.03.20100 #ZAHL!
316.02.200915.03.2011332
416.02.201001.03.2011332
501.02.201101.02.2011110
631.01.201101.02.2011220
701.02.201131.03.2011221
816.02.200915.03.2012121211

Formeln der Tabelle
ZelleFormel
C2=(JAHR(B2)>JAHR(HEUTE()))*12 + (JAHR(B2)=JAHR(HEUTE()))*MONAT(B2) - (JAHR(A2)=JAHR(HEUTE()))*(MONAT(A2)-1)
D2=WENN(UND(JAHR(A2)=JAHR(HEUTE()); JAHR(B2)=JAHR(HEUTE())); MONAT(B2)-MONAT(A2)+1;WENN(JAHR(B2)=JAHR(HEUTE()); MONAT(B2); WENN(UND(JAHR(A2)<JAHR(HEUTE()); JAHR(B2)>JAHR(HEUTE())); 12;WENN(UND(JAHR(B2)>JAHR(HEUTE()); JAHR(A2)=JAHR(HEUTE())); 13-MONAT(A2); ""))))
E2=DATEDIF(MAX(A2;"1.1."&JAHR(HEUTE())); MIN(B2;"31.12." &JAHR(HEUTE())); "ym")

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort
Anzeige
AW: Anzahl Monate im akt. Jahr
15.03.2011 12:57:13
Rudi
Hallo,
=DATEDIF(MAX(A2;"1.1."&JAHR(HEUTE()));MIN(B2;"31.12." &JAHR(HEUTE()));"ym")
Gruß
Rudi

312 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige