Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
184to188
184to188
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Tage in Monaten

Tage in Monaten
21.11.2002 15:43:31
Marco
hallo zusammen,

ich möchte berechnen wieviele tage im zeitraum 01.02.02-15.04.02 auf jeden einzelnen monat entfallen. für dieses bsp.:
januar 2002 = 0
februar 2002 = 28
...
april 2002 = 15
mai 2002 = 0

...

wer hat eine lösung? bitte kein vba!

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Monatstage zählen (Array)
21.11.2002 16:43:18
WF
Hi Marco,
aus der mail von excelformeln heraus erhielt ich ne Fehlermeldung und hab sie Dir nochmals zugeschickt; - die ist wohl auch nicht angekommen?
stimmt Deine Adresse: mstrote@yahoo.com

Das Anfangsdatum steht in A1; - das Enddatum in A2.
In B1 steht Januar, in C1 Februar, in D1 März usw.

in B2 steht die Array-Formel:
{=SUMME((MONAT(ZEILE(INDIREKT($A1&":"&$A2)))=SPALTE()-1)*1)}
bis M2 kopieren

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.

trapp, trapp, trapp, trapp, trapp, brrrrr
WF

http://www.excelformeln.de/
die ultimative Formelseite


Anzeige
Re: Monatstage zählen (Array)
22.11.2002 11:05:25
Marco
hallo wf,

die formel arbeitet korrekt. vielen dank.
ich habe die formel entsprechend meiner tabelle angepasst:
=SUMME((MONAT(ZEILE(INDIREKT($B28&":"&$H28)))=SPALTE()-14)*1)

die anfangsdaten stehen in B:B, die enddaten in H:H und ab zelle $O$1 habe ich die monate eingefügt.

wie müsste die formel geändert werden, wenn ich nur die monatsergebnisse eines jahres errechnen möchte. z.zt. erhalte ich für das bsp.: anfangsdatum 01.01.02, enddatum 01.01.03 für januar = 32. ich würde gerne nur januar 2002 = 31 und januar 2003 = 1 ermitteln! vielen dank für deine hilfe!

323 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige