Zahl in Buchstabe umwandeln

Bild

Betrifft: Zahl in Buchstabe umwandeln von: Claudi
Geschrieben am: 25.02.2005 14:21:41

Hallo zäme

Ich arbeite an einem Makro, jetzt möchte ich in eine Zelle die Formel
=MITTELWERT(C2;O2) schreiben. Das O ist jedoch dynamisch bestimmt worden. Und davon weiss ich nur die Zahl, also 15. (O ist 15. Buchstabe im Alphabet). Wie bringe ich es fertig, dass ich diese Formel in die Zelle bringe, also wie kann ich die 15 in ein O umwandeln. Das ist eigentlich das Problem. Mit Formulalocal und so, weiss ich dann schon wie es geht.

Gruss Claudi

Bild


Betrifft: AW: Zahl in Buchstabe umwandeln von: Hübi
Geschrieben am: 25.02.2005 14:33:07

Hi Claudi,

reicht dir das schon
Tabelle1
 ABCDEF
1Bis Spalte5    
22 1234
Formeln der Tabelle
A2 : =MITTELWERT(INDIREKT("C2:"&ADRESSE(2;B1)))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Gruß Hübi


Bild


Betrifft: AW: Zahl in Buchstabe umwandeln von: Claudi
Geschrieben am: 25.02.2005 14:40:03

Danke, aber wie mache ich es, wenn ich die Zahl, die du in B1 geschrieben hast in einer Variablen gepeichert habe??? Ich erstelle die Formel ja in einem Makro.


Bild


Betrifft: AW: Zahl in Buchstabe umwandeln von: Hübi
Geschrieben am: 25.02.2005 14:47:18

Hi Claudi,

Ulf hat es mit VBA gelöst.

Gruß Hübi


Bild


Betrifft: AW: Zahl in Buchstabe umwandeln von: Ulf
Geschrieben am: 25.02.2005 14:39:07

Sub Formel()
Dim Variable As Long
Variable = 15
[a1].FormulaR1C1 = "=AVERAGE(R2C3,R" & Variable & "C15)"
End Sub


Ulf


Bild


Betrifft: AW: Zahl in Buchstabe umwandeln von: Martin Beck
Geschrieben am: 25.02.2005 14:49:40

Hallo Claudi,

das Umwandeln ist unnötig. Versuch's so:

x = 15
Set ber = Range(Cells(2, 3), Cells(2, x))
ActiveCell.Formula = "=Average(" & ber.Address(False, False) & ")"

Gruß
Martin Beck


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zahl in Buchstabe umwandeln"