Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Arbeitstage über Zeiträume in Monaten

Arbeitstage über Zeiträume in Monaten
05.06.2023 13:02:31
Odion

Hallo, ich komme nicht wirklich weiter und wende mich an die Damen und Herren der dunklen Künste ;)

In meiner Firma würden wir gerne Ausfallzeiten nach Tagen berechnen (lassen). Dazu gibt es eine Excelliste in die die Mitarbeiter zu jedem Gerät die Ausfallzeiten in diesem Format notieren können: was - von - bis

Anlage3 | 23.04.2023 | 06.05.2023
Anlage5 | 02.02.2023 | 18.03.2023
Anlage3 | 20.02.2022 | 22.03.2023
Anlage1 | 13.12.2022 | 06.01.2023

Ich kann mir die Arbeitstage in dem Zeitraum (NETTOARBEITSTAGE(;)) angeben lassen und das mit SUMMEWENN(;;;) auch den Anlagen zuordnen (Anlage 3 hat im Beispiel 2 Einträge).
Jetzt würde ich gerne den Zeitram in die einzelnen Monate splitten. zB Anlage5 fällt 32AT aus (geht schon) , aber auch das: 19AT im Februar und 13AT im März. Anlage 1 fällt zB Tage in 2022 und 2023 aus, das würe ich auch gerne berücksichtigen (auch nach Monaten, aber auch im Jahr 2022 soundso viel und 2023 soundso viel)
Wie könnte eine einfache Lösung aussehen?

Danke, Odion

11
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Arbeitstage über Zeiträume in Monaten
05.06.2023 13:25:06
onur
"Wie könnte eine einfache Lösung aussehen?" Als erstes solltest du mal eine (Beispiels-) Datei - mit Wunschergebnis - posten, damit nicht WIR eine erstellen müssen.


AW: Arbeitstage über Zeiträume in Monaten
05.06.2023 13:53:33
Odion
Hi, ich probier es - ich habe ein Beispiel angehängt. Das erste Blatt ist die Datenerfassung, das zweite die Auswertung. Ich habe alles, was ich mir einbilde grün gemacht - funktioniert natürlich nicht und alle Zahlen sind zufällig gewählt und stehen nur drin, damit die Idee vermittelt werden kann.

Ich hatte auf eine Formel in jeder Zeile der Monatstabelle gehofft, die in etwa so funktioniert: suche zu Name in Spalte A in "Auswertung" alle Tage aus "Erfassung", die dem namen zuzuordnen sind und zähle nur die Tage, die dem Monat der Spalte in "Auswertung" zuzuordnen sind.

https://www.herber.de/bbs/user/159472.xlsx


Anzeige
AW: Arbeitstage über Zeiträume in Monaten
05.06.2023 14:07:46
Der Steuerfuzzi
Hallo,

hier mal eine "allgemeine" Formel zur Ermittlung der Ausfallzeiten für eine gewisse Periode:
{=SUMME(NETTOARBEITSTAGE.INTL(WENN($B$6:$B$500Auswertungsende;Auswertungsende;$C$6:$C$500);1)*($B$6:$B$500=Auswertungsende)*($C$6:$C$500>=Auswertungsbeginn)*($A$6:$A$500=Anlage))}
Achtung! Matrixformel, bei älteren Excel-Versionen mit Strg+Shift+Enter abschließen.

Jetzt kannst Du ganz einfach die Zeiten entsprechend einfügen. Bei Jahren z. B. so (Formel für Zelle D3 auf Blatt Auswertung):
{=SUMME(NETTOARBEITSTAGE.INTL(WENN(Erfassung!$B$6:$B$500DATUM(D$1;12;31);DATUM(D$1;12;31);Erfassung!$C$6:$C$500);1)*(Erfassung!$B$6:$B$500=DATUM(D$1;12;31))*(Erfassung!$C$6:$C$500>=DATUM(D$1;1;1))*(Erfassung!$A$6:$A$500=$A3))}
Die Formel kannst Du dann nach unten und rechts kopieren. Für die Monate kannst Du es bestimmt selber anpassen.


Anzeige
AW: Arbeitstage über Zeiträume in Monaten
05.06.2023 14:08:30
Der Steuerfuzzi
Ergänzung: Was soll er denn berechnen, wenn das Enddatum leer ist?


AW: Arbeitstage über Zeiträume in Monaten
05.06.2023 14:12:31
Odion
UI! ! ! Danke, ja, da muss ich mich reindenken, aber schon mal VIELEN DANK!
Wenn das Enddatum leer ist, lass ich ihn das heutige Datum nehmen.


AW: Arbeitstage über Zeiträume in Monaten
05.06.2023 14:14:07
Der Steuerfuzzi
Dann wird es etwas länger:
{=SUMME(NETTOARBEITSTAGE.INTL(WENN(Erfassung!$B$6:$B$500DATUM(D$1;12;31);DATUM(D$1;12;31);WENN(Erfassung!$C$6:$C$500=0;HEUTE();Erfassung!$C$6:$C$500));1)*(Erfassung!$B$6:$B$500=DATUM(D$1;12;31))*(WENN(Erfassung!$C$6:$C$500=0;HEUTE();Erfassung!$C$6:$C$500)>=DATUM(D$1;1;1))*(Erfassung!$A$6:$A$500=$A3))}


Anzeige
AW: Arbeitstage über Zeiträume in Monaten
05.06.2023 14:15:14
Der Steuerfuzzi
Ups, das Forum hat die > Zeichen verschluckt. Hier nochmal:
=SUMME(NETTOARBEITSTAGE.INTL(WENN(Erfassung!$B$6:$B$500DATUM(D$1;12; 31);DATUM(D$1;12;31);WENN(Erfassung!$C$6:$C$500=0;HEUTE();Erfassung!$C$6:$C$500));1) *(Erfassung!$B$6:$B$500=DATUM(D$1;12;31))*(WENN(Erfassung!$C$6:$C$500=0;HEUTE(); Erfassung!$C$6:$C$500)>=DATUM(D$1;1;1))*(Erfassung!$A$6:$A$500=$A3))


AW: Arbeitstage über Zeiträume in Monaten
05.06.2023 14:21:10
Der Steuerfuzzi
Also zwischen "Erfassung!$B$6:$B$500" und "DATUM(D$1;12; 31)" muss ein Kleinerzeichen stehen


AW: Arbeitstage über Zeiträume in Monaten
05.06.2023 14:29:54
Odion
Jetzt spuck er was aus!


Anzeige
AW: Arbeitstage über Zeiträume in Monaten
05.06.2023 14:24:14
Odion
Prima, danke dir - so weis ich wo die Reise hin geht. Mein Excel (Excel 365 for Enterprise) erkennt das nicht als Formel, aber ich kann mir jetzt einen Weg an deiner Lösung entlang stricken =)


AW: Arbeitstage über Zeiträume in Monaten
05.06.2023 14:24:14
Odion
Prima, danke dir - so weis ich wo die Reise hin geht. Mein Excel (Excel 365 for Enterprise) erkennt das nicht als Formel, aber ich kann mir jetzt einen Weg an deiner Lösung entlang stricken =)

326 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige