Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
492to496
492to496
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Tage in Monaten
01.10.2004 14:46:02
Tuddle
Hallo,
habe bereits eine Teil-Lösung im Archiv gefunden, hierbei werden allerdings alle Tage im Januar als Ergebnis ermittelt und nicht wie gewünscht nur die Tage im Januar d. angebenen Jahres.
Ich möchte berechnen wieviele tage im zeitraum 01.02.03-15.04.04 auf jeden
einzelnen Monat des Jahres entfallen. für dieses bsp.:
januar 2003 = 31
Januar 2004 = 31
Bei Anwendung der Formel :
{=SUMME((MONAT(ZEILE(INDIREKT($A1&":"&$A2)))=SPALTE()-1)*1)}
erscheint bei Januar 2004 das Ergebnis 62 und nicht wie gewünscht 31.
Vielen Dank vorab

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Tage in Monaten
th.heinrich
hi wer ?
bitte mit realvornamen posten.
keine ahnung wie Deine tabelle aufgebaut ist (ein upload ist moeglich).
bin kein formel profi, aber lass dies
&":"&$A2
mal weg
gruss thomas
ich bin ohne Name
01.10.2004 20:01:58
..
.
AW: ich bin ohne Name
03.10.2004 16:57:11
Gesine
Hy Thomas,
vorab kurze Vorstellung - heiße Gesine (Spitz/Rufname:Tuddle).
Zum Problem:
In der Zelle A1 steht das Startdatum: 01.02.2003
In der Zelle A2 steht das Enddatum: 15.02.2004
In der Zelle B1 steht Januar 2003 in C1 Januar 2004
Das Soll Ergebnis lautet: für Zelle B2: 31, für Zelle C2: 31
Bei Anwendung der Matrixformel {=SUMME((MONAT(ZEILE(INDIREKT($A1&":"&$A2)))=SPALTE()-1)*1)}in Zelle B2 & C2 wird aber 62 bei beiden angezeigt, anstatt die 31.
Vielen dank und schöne Grüße
Anzeige
AW: Tage in Monaten
th.heinrich
hallo Gesine,
der "ich bin ohne Name" beitrag war nicht von mir.
hilft dies weiter ?
Tabelle1
 ABC
101.02.0301.01.0301.01.04
215.02.043131
Formeln der Tabelle
B2 : {=SUMME((MONAT(ZEILE(INDIREKT($A$1&":"&$A$2)))=SPALTE()-1)*1)}
C2 : {=SUMME((MONAT(ZEILE(INDIREKT($A$1&":"&$A$2)))=SPALTE()-2)*1)}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
gruss thomas
Anzeige
AW: Tage in Monaten
08.10.2004 08:00:10
Gesine
Hallo Thomas,
leider funktioniert die von Dir angegebene Formel nicht richtig. Wenn ich das Datum später (nachdem die Formel eingegeben wurde) ändere, erfolgt keine Aktualiserung.
Hast Du noch einen Lösungsvorschlag?
Vielen Dank und schöne Grüße
Gesine

323 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige