Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Kalender füllen, Wochentage berechnen

Kalender füllen, Wochentage berechnen
tursiops
Hallo!
Ich benötige etwas Hilfe. Ich möchte den Kalender siehe Anhang anhand des in A1 eingegebenen Datums füllen und die Anzahl der Wochentage im Monat ausrechnen lassen.
Mein Problem ist nun, wie ich per Formel den ersten Wochentag ermitteln kann. Wenn ich es schaffe in der ersten Kalenderwoche am korrekten Wochentag eine 1 zu hinterlegen, sollte der rest per Formel ganz gut zu lösen sein.
Gruß tursiops
https://www.herber.de/bbs/user/79580.xls

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
ist doch ganz leicht
28.03.2012 08:28:01
Matthias
Hallo
Das Beispiel zeigt März 2013
 BCDEFGH
3MoDiMiDoFrSaSo
4    123

Formeln der Tabelle
ZelleFormel
B4=WENN(WOCHENTAG($A$1;2)=SPALTE()-1;1;"")
C4=WENN(B4="";WENN(WOCHENTAG($A$1;2)=SPALTE()-1;1;"");B4+1)
D4=WENN(C4="";WENN(WOCHENTAG($A$1;2)=SPALTE()-1;1;"");C4+1)
E4=WENN(D4="";WENN(WOCHENTAG($A$1;2)=SPALTE()-1;1;"");D4+1)
F4=WENN(E4="";WENN(WOCHENTAG($A$1;2)=SPALTE()-1;1;"");E4+1)
G4=WENN(F4="";WENN(WOCHENTAG($A$1;2)=SPALTE()-1;1;"");F4+1)
H4=WENN(G4="";WENN(WOCHENTAG($A$1;2)=SPALTE()-1;1;"");G4+1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias
Anzeige
Erledigt
28.03.2012 08:34:06
tursiops
Das klappt super!
Vielen Dank!!!
Gruß tursiops
AW: Kalender füllen, Wochentage berechnen
28.03.2012 13:26:15
tursiops
Hallo nochmals!
Anbei sende ich nochmals die Tabelle mit der Kalenderfunktion. Inzwischen klappt alles recht zuverlässig, bis auf die Berechnung der Kalenderwoche. Ich habe extra eine Formel benutzt, die die Berechnung nach der deutschen DIN 1355 / DIN EN 28601 vornehmen soll. Trotzdem erhalte ich ein falsches Ergebnis. Die erste KW fehlt komplett.
Weiß hier jemand Rat?
https://www.herber.de/bbs/user/79590.xls
Gruß tursiops
AW: Kalender füllen, Wochentage berechnen
28.03.2012 17:13:24
Hajo_Zi
warum benutzt Du nicht die Funktion von Excel 2010? Schalter 21

Anzeige
Kalender: ein Klammerpaar fehlt komplett ! ;o)
29.03.2012 00:00:40
Matthias
Hallo
Falsch
=KÜRZEN(A1-WOCHENTAG(A1;2)-DATUM(JAHR(A1+4-WOCHENTAG(A1;2));1;-10))/7
Richtig:
=KÜRZEN((A1-WOCHENTAG(A1;2)-DATUM(JAHR(A1+4-WOCHENTAG(A1;2));1;-10))/7)
2011 hatte 52 Kalenderwochen und nicht 53
 ABCDEFGHI
1Donnerstag, 1. Dezember 201131Tage im Monat  
2         
3DezemberMoDiMiDoFrSaSo 
448   01020304 
54905060708091011 
65012131415161718 
75119202122232425 
852262728293031  
9         
10 4445554 


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Dann muss 2012 auch mit 52 beginnen! Richtig?
 ABCDEFGHI
1Sonntag, 1. Januar 201231Tage im Monat  
2         
3JanuarMoDiMiDoFrSaSo 
452      01 
5102030405060708 
6209101112131415 
7316171819202122 
8423242526272829 
953031      
10 5544445 


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias
Anzeige
Erledigt
29.03.2012 06:43:35
tursiops
Hallo!
Vielen Dank, jetzt klappt es hervorragend.
@Hajo: die Funktion ist so weit mir bekannt ist nur in Excel 2010 möglich.
Die Datei wäre daher nicht mehr kompatibel zu älteren Versionen.
Gruß tursiops

303 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige