Microsoft Excel

Herbers Excel/VBA-Archiv

WENN-UND-ODER...

Betrifft: WENN-UND-ODER... von: Jean-Pierre
Geschrieben am: 30.08.2004 21:45:35

Hallo zusammen,

hänge gerade etwas fest...

In Zelle F2 habe ich folgende Formel WENN(UND(C2>0;D2>0;E2>0);C2*D2*E2*100;"")~f~
in Zelle K2 ~f~ WENN(UND(H2>0;I2>0;J2>0);H2*I2*J2*100;"") ~f~
in Zelle P2 ~f~ WENN(UND(M2>0;N2>0;O2>0);M2*N2*O2*100;"")

in Zelle R2 möchte ich nun via WENN(UND(ODER die Summe aus F2+K2+P2 haben auch wenn die teilweise leer sind.
Beispiel:
In F2, K2 und P2 steht nichts dann gleich 0
In F2 steht 100 in K2 und P2 nichts dann gleich 100
In F2 und K2 steht jeweils 100 in P2 nichts dann gleich 200 usw.

Hat da jemand einen Rat bzw. eine Info für mich???

Gruß aus Berlin
Jean-Pierre

  


Betrifft: AW: WENN-UND-ODER... von: Franc
Geschrieben am: 30.08.2004 21:51:27

=SUMME(F2+K2+P2)


  


Betrifft: AW: WENN-UND-ODER... von: Jean-Pierre
Geschrieben am: 30.08.2004 21:54:29

Hallo Franc,

danke für die Info....doch das geht eben leider nicht!
Es erscheint die Meldung #WERT! und die kann ich leider nicht gebrauchen.

Gruß aus Berlin
Jean-Pierre


  


Betrifft: AW: WENN-UND-ODER... von: Franc
Geschrieben am: 30.08.2004 21:58:53

Dann hast du aber was anderes ausser Zahlen darin stehen.
Wenn es geht dann lad die Tabelle hoch und ich kann evtll. sehen woran es liegt.


  


Betrifft: AW: WENN-UND-ODER... von: Jean-Pierre
Geschrieben am: 30.08.2004 22:02:20

Hallo Franc,

hier ist die Datei:
https://www.herber.de/bbs/user/10320.xls


Gruß aus Berlin
Jean-Pierre


  


Betrifft: AW: WENN-UND-ODER... von: Franc
Geschrieben am: 30.08.2004 22:23:39

sry da wüsst ich jetzt auch nicht weiter.


  


Betrifft: AW: WENN-UND-ODER... von: mealone
Geschrieben am: 30.08.2004 22:47:35

hallo jp

ersetze in deinen formel das "" im sonst teil durch 0
dann funktioniert die einfache summenbildung
cu mealone


  


Betrifft: AW: WENN-UND-ODER... von: Franc
Geschrieben am: 31.08.2004 00:38:28

Das ist richtig aber ich glaube das will er nicht, das die ganze Tabelle voll mit 0-en ist.


  


Betrifft: AW: WENN-UND-ODER... von: HermannZ
Geschrieben am: 31.08.2004 11:25:24

Hallo Jean-Pierre

vieleicht so??

https://www.herber.de/bbs/user/10332.xls

Gruß hermann


  


Betrifft: o.T: Dank an Hermann und an die anderen Helfer von: Jean-Pierre
Geschrieben am: 31.08.2004 14:36:53

Hallo Hermann,

vielen Dank! Genau so wollte ich das haben!!!

Dank auch an Franc und Mealone für die Mühe...


Gruß aus Berlin
Jean-Pierre